Closed Bug 104506 (PluginDoc) Opened 18 years ago Closed 10 years ago

Working plug-ins status and files needed for Mozilla

Categories

(Developer Documentation :: General, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: wolruf, Unassigned)

References

Details

Here's some information about plug-ins that are known to work, which files are 
needed, what does not work, etc. From personal research and help from people 
like Alvaro on #mozillazine (and plenty of others).
Might be worth making bug 100230 depend on this one.
Perhaps we can make a table with several common elements: latest version, 
minimal version, NS4.x needed, etc. Should XUL plug-ins be part of a separate 
document (Jabberzilla, etc.) ?

 * Win32 platform:
  + Flash: works. Installer will decompress the file without NS4.x installed. 
Latest version: 5.0r41. Known not to work: v.3.0 (bug 101495). File needed: 
npswf32.dll.
  + Shockwave: works. Installer does not work if NS4.x not installed. File 
needed: np32dsw.dll (perhaps ShockwavePlugin.class ?).
  + Windows Media Player: works. You have to copy the files manually from 
C:\Program Files\Windows Media Player\ to the plugins\ directory: npdrmv2.dll 
npdrmv2.zip npwmsdrm.dll npdsplay.dll and npds.zip. Only v.7.1 works as plug-
in, *not* v.7.0 nor v.6.4 (verified by 2 other people).
  + Quicktime: works. Files needed: npqtplugin.dll npqtplugin2.dll 
npqtplugin3.dll npqtplugin4.dll npqtplugin5.dll (perhaps 
QuickTimePlugin.class ?). Make sure you have v.5.0.2 or above otherwise MIME 
types may interfere with Mozilla MIME types' own handling (bug 69719). v.4.1.2 
works however (except it captures some MIME types).
  + RealPlayer: works. Real G2 and above (v.7.0 & 8.0) work. NS4.x is needed to 
get the plug-in files: nppl3260.dll and rpcl3260.zip (verified by other people).
  + Acrobat Reader: works. v.5.0 (I remember v.4.0 worked too). File needed: 
nppdf32.dll.
  + Java: works. v.1.3.0_01 1.3.1 and 1.4beta2. 1.3.1 is recommended. File 
needed: npoji600.dll (or npoji610.dll if 1.4beta2).
  - Cult3D: not supported.
  ? Scol Engine: untested.

 * Linux platform.
  + Flash: works, the installer will decompress the file without NS4.x 
installed. Latest version: 5.0r47. File needed: libflashplugin.so.
  + Java: not so stable (numerous Linux-specific bug reports), bug 86591 is 
fixed however. 1.3.0_01 and 1.3.1 (1.3.1 "recommended"). File needed: none, 
just a link ('ln -s') to libojins600.so. Bug 100230 covers RH7.1.
  + Real: v.8.0 is known to work.
  + Plugger: v.3.3 and above seem to work (from Plugger release notes, 
untested), seems buggy however: bug 85542.
  ? Scol Engine: untested.

 * MacOS platform.
 * Other (Solaris, *BSD, MacOSX, etc.) platforms.

I wonder if .zip and .class are even needed because bug 97362 mentions they're 
not even being parsed.
Blocks: 100230
Hendikins, would be cool if you attach your plugin doc to the bug, once again I
promise to add my mac info ;-).
cc:ing Arun. I'm not sure all that info is 100% correct. Shockwave, Quicktime,
and Acrobat should have just recently released installers that can find a Gecko
embedding browser. Need to verify they still work after using the "Mozilla"
installer vs. the Netscape commercial one.
No this information is incorrect for Windows 2000 Server with NPOJI600.dll 
version 1.3.1.0.  Where he is saying to link to for Java support is beyond me.  
But QuciTime 5 plugins versions 5.0.2.15 do nothing at all.  QuickTime 4 plugin 
npqtplugin.dll version 4.1.2.40 is the only plugin necessary to get sound from 
a wav file.  But this with the Java plugin I mentioned crashes ALL Mozilla.  
Furthermore ALL Mozilla will crash with the QuicTime plugins going to a 
embedded RealPlayer Web page.  Don't know about the Media Player Plugins.  The 
trouble is to keep Java working and then to see which plugins crash the 
browser.  But right now if I want sound, no Java and no RealPlayer Mozilla 
crashes.  If I want Java, no sound and no Real Player support.  Trie for ALL 
versions of Mozilla.  And with this buggy of an app, I really doubt it's time 
has come.
Reassigning to Ian Oeschger.
Assignee: rudman → oeschger
docs for plugins: ACCEPTING
Status: NEW → ASSIGNED
reporter: I do believe that .class files are needed. That "invalid ELF Header"
just means that they're not loaded as plugins.
I suppose that the actual plugin (.dll / .so file) does require that file, though.
When this document gets checked in, add an item to the most recent release
notes bug and i'll add a link to it. I don't want to add all of this to 
the release notes themselves, as someone suggested in the 0.9.6 release 
notes.
I'm working on some Win32 docs... I'd love to reassign to self, but I'm not back
at home yet (which isn't such a bad thing, come to think of it).
>  - Cult3D: not supported.

Any chance of getting the vendor to support Mozilla-based browsers? Tech
Evangelism-related?
Blocks: PluginDocMac
No longer blocks: PluginDocMac
Depends on: PluginDocMac
 * Win32 platform:
  + Cortona VRML v3.1.0.54 works, at least under Win98. Installer will not detect
    Mozilla, but if you have Netscape 4 installed it will install the plugin files
    to the Netscape 4 directory. You can then copy them to the Mozilla plugins
    directory. Files needed: "npCortona.dll" and "plywood.jar"

Note1: Download installer from http://www.parallelgraphics.com/bin/cortvrml.exe
Note2: Technically you should be able to extract the installer files and copy the
       plugin files directory. However, while "cortvrml /x" does give you the
       dialog to pick files for extraction, no files are listed. May differ on
       other platforms.
PluginDoc (http://plugindoc.mozdev.org) should go some way towards getting this
fixed up a bit...
Blocks: 145919
Since there's getting to be quite a lot of entries, particularly on Windows,
could they be listed alphabetically? (Just nitpicking really...:o)
Depends on: PluginDocOS2
Adding OS X Plugins bug to dependencies
No longer blocks: 100230, 145919
Depends on: PluginDocOSX
Blocks: 145919
That bug is a duplicate of bug 119045, which is a dependency of the MacOS X
documentation bug (bug 177482). 

Please do not add dependencies to this bug, add them to the OS-specific bug instead.

Also, I should have PluginDoc in alphabetical order shortly.
No longer blocks: 145919
Reassigning to self after speaking to Ian on IRC.
Assignee: oeschger → nobandwidth
Status: ASSIGNED → NEW
apologies for spam.
Status: NEW → ASSIGNED
Alias: PluginDoc
I'm not sure if it was already asked somewhere else, but I would like to have
links to sample pages in the plugin-lists. That would allow me to check
immediately if the plugin works or not.
Depends on: 185452
Depends on: PluginDocMacosX
No longer depends on: PluginDocMacosX
(In reply to comment #0)

I just installed the LizardTech (MrSID) plugin, and although it is billed as
automatic, it automagically crashes the browser.  A message box for an invalid
authenticity certificate pops up, and if U click 'Yes' to accept it anyway, the
entire browser immediately crashes.  If U click 'No' instead, there is a link
(http://www.lizardtech.com/software/expressview/maninstall/exview_setup.exe) to
download the self-installer.

I am using this version of Mozilla:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616




> Here's some information about plug-ins that are known to work, which files are 
> needed, what does not work, etc. From personal research and help from people 
> like Alvaro on #mozillazine (and plenty of others).
> Might be worth making bug 100230 depend on this one.
> Perhaps we can make a table with several common elements: latest version, 
> minimal version, NS4.x needed, etc. Should XUL plug-ins be part of a separate 
> document (Jabberzilla, etc.) ?
> 
>  * Win32 platform:
>   + Flash: works. Installer will decompress the file without NS4.x installed. 
> Latest version: 5.0r41. Known not to work: v.3.0 (bug 101495). File needed: 
> npswf32.dll.
>   + Shockwave: works. Installer does not work if NS4.x not installed. File 
> needed: np32dsw.dll (perhaps ShockwavePlugin.class ?).
>   + Windows Media Player: works. You have to copy the files manually from 
> C:\Program Files\Windows Media Player\ to the plugins\ directory: npdrmv2.dll 
> npdrmv2.zip npwmsdrm.dll npdsplay.dll and npds.zip. Only v.7.1 works as plug-
> in, *not* v.7.0 nor v.6.4 (verified by 2 other people).
>   + Quicktime: works. Files needed: npqtplugin.dll npqtplugin2.dll 
> npqtplugin3.dll npqtplugin4.dll npqtplugin5.dll (perhaps 
> QuickTimePlugin.class ?). Make sure you have v.5.0.2 or above otherwise MIME 
> types may interfere with Mozilla MIME types' own handling (bug 69719). v.4.1.2 
> works however (except it captures some MIME types).
>   + RealPlayer: works. Real G2 and above (v.7.0 & 8.0) work. NS4.x is needed to 
> get the plug-in files: nppl3260.dll and rpcl3260.zip (verified by other people).
>   + Acrobat Reader: works. v.5.0 (I remember v.4.0 worked too). File needed: 
> nppdf32.dll.
>   + Java: works. v.1.3.0_01 1.3.1 and 1.4beta2. 1.3.1 is recommended. File 
> needed: npoji600.dll (or npoji610.dll if 1.4beta2).
>   - Cult3D: not supported.
>   ? Scol Engine: untested.
> 
>  * Linux platform.
>   + Flash: works, the installer will decompress the file without NS4.x 
> installed. Latest version: 5.0r47. File needed: libflashplugin.so.
>   + Java: not so stable (numerous Linux-specific bug reports), bug 86591 is 
> fixed however. 1.3.0_01 and 1.3.1 (1.3.1 "recommended"). File needed: none, 
> just a link ('ln -s') to libojins600.so. Bug 100230 covers RH7.1.
>   + Real: v.8.0 is known to work.
>   + Plugger: v.3.3 and above seem to work (from Plugger release notes, 
> untested), seems buggy however: bug 85542.
>   ? Scol Engine: untested.
> 
>  * MacOS platform.
>  * Other (Solaris, *BSD, MacOSX, etc.) platforms.
> 
> I wonder if .zip and .class are even needed because bug 97362 mentions they're 
> not even being parsed.
HOW-TO INSTALL THE CITRIX ICA PLUGIN
TO BE SEEN AS A PLUGIN IN MOZILLA FIREFOX


Situation:
When you use Firefox and browse to a Citrix Web Interface page, you get an error
message saying that you do not have the ICA Client, even when is is installed
and fully functionnal.

Solution:
To fix this problem, follow these steps to registrer your ICA Client to Firefox.

1-	Copy these files to C:\Program Files\Mozilla Firefox\plugins

These files are (by default) in C:\Program Files\Citrix\icaweb32 if you have
installed the Citrix ICA Web Client (tested with version 8.0).

npican.dll	(the ICA plugin itselft)
icalogon.dll
pscript.dll
sslsdk_b.dll
cgpcfg.dll
tcppserv.dll
cgpcore.dll
npicaNUI.dll	(located in C:\Program Files\Citrix\icaweb32\Resource\en)

2-	Restart Firefox.
Assignee: hendikins → nobody
Component: Help Viewer → Documentation Requests
Product: Documentation → Mozilla Developer Center
QA Contact: rudman → doc-request
Between plugindoc.mozdev.org and SUMO's plugin support at http://support.mozilla.com/en-US/kb/Popular+plugins this resolves the ideas in comment 0. If you disagree with this closing please reopen.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Component: Documentation Requests → Documentation
Component: Documentation → General
Product: Mozilla Developer Network → Developer Documentation
You need to log in before you can comment on or make changes to this bug.