Closed Bug 1045090 Opened 8 years ago Closed 8 years ago

Update the documentation to reflect the treeherder-ui dependency

Categories

(Tree Management :: Treeherder, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: davehunt, Assigned: emorley)

References

Details

Attachments

(1 file)

There are a couple of places in the documentation that assume treeherder-ui is optional, however it now appears to be a requirement. For example, the installation should mention that both treeherder-server and treeherder-ui repositories should be cloned.
Priority: -- → P2
Presume this is the cause of:

[/c/src/treeherder/service]$ vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
There are errors in the configuration of this machine. Please fix
the following errors and try again:

vm:
* The host path of the shared folder is missing: ../treeherder-ui
Attached patch Update docsSplinter Review
Ideally we'd:
(a) Have a Vagrantfile.local that's in the .gitignore
(b) Have the default treeherder-service Vagrantfile not rely on the ui repo

But for now, lets at least update the docs to reflect the current state.
Assignee: nobody → emorley
Status: NEW → ASSIGNED
Attachment #8476710 - Flags: review?(mdoglio)
(In reply to Ed Morley [:edmorley] from comment #2)
> Ideally we'd:
> (a) Have a Vagrantfile.local that's in the .gitignore

Filed bug 1056865.

> (b) Have the default treeherder-service Vagrantfile not rely on the ui repo

Filed bug 1056872 & also bug 1056868 (since the latter was the cause for my comment 1 error).
Attachment #8476710 - Flags: review?(mdoglio) → review+
Depends on: 1057703
https://github.com/mozilla/treeherder-service/commit/ecfe1f6d2594e408cda82888e233d31184e08c5c

However bug 1057703 is required before the live RTD page will reflect the change.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.