Pre-select the first popup entry when autoFill suggests a match

RESOLVED DUPLICATE of bug 951624

Status

()

Firefox
Location Bar
RESOLVED DUPLICATE of bug 951624
3 years ago
3 years ago

People

(Reporter: mak, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

we should pre-select the first popup entry when autoFill matches, so that a key_down will go to the second entry and it will be clearer what is going to happen on Enter.
Flags: firefox-backlog+
See also bug 951624

Updated

3 years ago
Duplicate of this bug: 1044979
Blocks: 1045985
Blair, is bug 951624 somehow addressing this, can we leverage the code you are adding or do we need specific code for this case?
Flags: needinfo?(bmcbride)
(In reply to Marco Bonardo [:mak] from comment #3)
> Blair, is bug 951624 somehow addressing this, can we leverage the code you
> are adding or do we need specific code for this case?

Yea, bug 951624 already covers this. It's a bit of an all-or-nothing change if we want autofill to work at all.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(bmcbride)
Resolution: --- → DUPLICATE
Duplicate of bug: 951624
Flags: firefox-backlog+
No longer blocks: 1045985
Blocks: 1086990
Duplicate of this bug: 1087589
You need to log in before you can comment on or make changes to this bug.