Other messages not shown after deleting an IMAP folder what has been created by procmail scripts

RESOLVED INCOMPLETE

Status

SeaMonkey
MailNews: Message Display
RESOLVED INCOMPLETE
4 years ago
2 years ago

People

(Reporter: TT, Unassigned)

Tracking

SeaMonkey 2.26 Branch
x86_64
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:20.0) Gecko/20100101 Firefox/20.0 (Beta/Release)
Build ID: 20130329030832

Steps to reproduce:

After deleting an IMAP folder (a subfolder of the Inbox folder), if I click on another sub-folder and try to view a message in that sub-folder, the message is not displayed.  I need to close and re-open the Mail window to fix this problem.

Thunderbird 17.0.5 does not appear to have this problem.
(Reporter)

Updated

4 years ago
OS: Linux → Mac OS X

Comment 1

2 years ago
@reporter:
Still a problem for you? Please us your current SM and OS version
Flags: needinfo?(mozilla.org)
(Reporter)

Comment 2

2 years ago
Yes, this is still a problem.  I'm using Seamonkey 2.39 on Mac OS 10.9.
Flags: needinfo?(mozilla.org)

Comment 3

2 years ago
NOT reproducible with  English SeaMonkey 2.41a1  (X11; Linux x86_64; rv:44.0)  Gecko/20100101 Firefox/44.0 Build 20151103003001  (Classic Theme) on VirtualBox Ubuntu 14.04 LTS
NOT reproducible with  SeaMonkey German 2.39 final Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0 from official download area)  Gecko/20100101  Firefox/42.0  Build 20151103191810  (Classic Theme) on German WIN7 64bit:

For both cases I created 2 subfolders for inbox, moved some e-mails from inbox to subfolders, closed and reopened SM, deleted one of the new subfolders with <del>. After click on remaining subfolder in Folder Pane, emails are shown in thread Pane and after a click on such an e-mail contents appears in Message Pane.

this might be related to OS or 1000 other possible reasons.

@Reporter, please:
a) Contribute a problem related step by step instruction containing every 
   key press and every mouse click how to reproduce your problem due to 
   <https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines>
   (similar to report in Bug 1139273) "the message is not displayed" is too rare.
   Don't you see it in Thread Pane or is contents missing in Message Pane? 
   And so on
b) Attach screenshots with comments if you believe that that might explain the 
   problem better than a text comment. Best way is to insert your screenshots
   into a OOo or LibreOffice DRAW document and to add comments 
   that explain what you want to show (attach .png or PDF from source document)
c) add information 
c1) concerning your Operating System (Language)
c2) concerning your SM localization (UI language, Locale setting)
c3) SM settings that might be related to your problems 
    May be you should attach a copy of menu 
   'Help → Trouble shooting information”
c4) how you launch SM (Double click on document? console? …)
c5) Whether problem persists in safe mode without add-ons
c6) Wheter problem persists in newly created profile
c7) everything else crossing your mind after you read linked texts
c8) your e-mail service provider?
d) If possible you should create a test e-mail account at your e-mail-service-
   provider, fill it with necessary contents and tell  IMAP account user data
   to few testers here (by personal mail), so that we can test under 
   exactly the same conditions. 
e) Try Thunderbird and tell whether the problem is reproducible there.
Flags: needinfo?(mozilla.org)
(Reporter)

Comment 4

2 years ago
The only thing I can add is that the folders are created dynamically by the IMAP server, via a procmail script.  They're not folders that I created in Seamonkey.  I have procmail scripts that creates subfolders to automatically filter mail.  Seamonkey handles the creation of folders just fine.  But when I delete the folder, I need to close the Mail window, otherwise I will have difficulty reading other messages in other folders.

The problem does NOT occur in Thunderbird.  This happens only in Seamonkey.
Flags: needinfo?(mozilla.org)

Comment 5

2 years ago
Procmail seems to be some really old stuff
I did not find an obvious procmail DUP with <https://bugzilla.mozilla.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=DUPs1045107procmail&sharer_id=41036> or a more general DUP with <https://bugzilla.mozilla.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=DUPs1045107visibility&sharer_id=41036&list_id=12697165>

I close this one as INCOMPLETE for now.

@Reporter:
Well, if you don't want to answer to such easy questions like whether the e-mail is completely missing in the Thread Pane or Message contents is not shown in Message Pane we can't do anything here until somebody contributes required information.

Please feel free to reopen this Bug if when you can contribute required information due to <https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines>
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INCOMPLETE
Summary: Cannot view other messages after deleting an IMAP folder → Other messages not shown after deleting an IMAP folder what has been created by procmail scripts
You need to log in before you can comment on or make changes to this bug.