OS X window frame: 8 extra pixels on top content margin

RESOLVED DUPLICATE of bug 967425

Status

()

RESOLVED DUPLICATE of bug 967425
4 years ago
4 years ago

People

(Reporter: garvan, Unassigned)

Tracking

32 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8463540 [details]
Screenshot 2014-07-28 14.55.44.png

See screenshot, see space above close button to window edge. 
I measure 8 extra px vs. native OS X apps.
This is intentional because it centers the window buttons vertically in the titlebar. It was implemented in bug 851652.
(Reporter)

Comment 2

4 years ago
IMHO, here is the litany of problems this creates:
- the upper-right expand window button is also placed in a non-standard position.
- makes the app's look and feel non-native, and native look and feel is arguably a big deal in Apple-land
- creates wasted space (for those of us who like minimal window chrome)
- it misaligns the buttons vertically from the window title (see screenshot).
The person you'll need to talk to is Stephen Horlander, not me.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 967425
(Reporter)

Comment 4

4 years ago
Thanks Markus, it is a dup of 967425.
You need to log in before you can comment on or make changes to this bug.