improve message display performance by selectively notifying the header sink

VERIFIED DUPLICATE of bug 22960

Status

SeaMonkey
MailNews: Message Display
P1
normal
VERIFIED DUPLICATE of bug 22960
17 years ago
13 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: Scott MacGregor)

Tracking

({perf})

Trunk
mozilla0.9.7
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

improve message display performance by selectively notifying the header sink

depending on our view mode ("mail.show_headers"), we don't have to tell he 
header sink about all the headers.

except in view all mode, we only need to tell the sink about subject, cc, to, 
from, date, and, newsgroups.

there are many headers we don't need to tell the sink about.

here comes a patch.
(Assignee)

Comment 1

17 years ago
i already have a mailnews perf bug where i talk about doing this. This should be
duped against my bug thanks.
I also #if 0 out some PRTime code that wasn't being used.
Status: NEW → ASSIGNED
over to mscott.

mscott points out there are a few more headers we need to allow through, see 
gExpandedHeaderList in msgHdrViewOverlay.js

as far as the PRTime code goes, double check.  We already call HandleHeader() 
on the sink with the string we get back from GenerateDateString().

Assignee: sspitzer → mscott
Status: ASSIGNED → NEW
Attachment #53383 - Attachment is obsolete: true

Comment 6

17 years ago
Marking P1 because it's message display performance. If you don't think this fix
warrants this priority, then please change it.
Keywords: nsbeta1+
Priority: -- → P1
Target Milestone: --- → mozilla0.9.7
This bug has lived as bug 22960 for quite some time.  Any reason to keep them 
seperate?
Keywords: perf
QA Contact: esther → stephend
patch is now part of patch for #22960

*** This bug has been marked as a duplicate of 22960 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.