Creating events per drag doesn't take default status values into account

RESOLVED FIXED in 3.7

Status

Calendar
Calendar Views
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: Robert Brand, Assigned: Decathlon)

Tracking

Lightning 3.3

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Bug 998281 gave enhanced preferences for a default event status. While creating a new event per drag in day or week view, these prefs aren't taken into account, the event has no default status.
I guess you have to add one more call for setDefaultItemValues(item) somewhere around http://mxr.mozilla.org/comm-central/source/calendar/base/content/calendar-views.js#35 (that works for me extension-wise).

Seen with Lightning 3.3 and 3.6a1.
(Assignee)

Comment 1

4 years ago
Created attachment 8464304 [details] [diff] [review]
patch - v1

If we use setDefaultItemValues() for the default status we can also use it to set the calendar, alarms and start/end date-times (so we avoid to set these elements twice).

Alternatively we can simply add this line inside the function createNewEvent:
item.setProperty("TRANSP", cal.getEventDefaultTransparency(aForceAllday));
Assignee: nobody → bv1578
Status: NEW → ASSIGNED
Attachment #8464304 - Flags: review?(philipp)
Attachment #8464304 - Flags: review?(philipp) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
OS: Windows 7 → All
Hardware: x86 → All
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/19f995a8be86>
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 3.7
Keywords: checkin-needed
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1140998
You need to log in before you can comment on or make changes to this bug.