HTTP Authentication of embedded auth realms

VERIFIED DUPLICATE of bug 54349

Status

()

VERIFIED DUPLICATE of bug 54349
17 years ago
16 years ago

People

(Reporter: marian, Assigned: neeti)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
OK, funny description, I know. Here is what it should tell:

Lets say you have an access limited site with an auth realm http://my.site.com/
an an "inner" realm http://my.site.com/somerealm/ (e.g. for a certain sub-group
of the first realm's users).

When diretctly going to the URL http://my.site.com/somerealm/ without
authenticating at http://my.site.com/, we have the following problem: If the
page http://my.site.com/somerealm/ (or it's sub pages) links a style sheets
(maybe also images?) from somewhere outside the realm , e.g.
http://my.site.com/images/..., mozilla won't load the linked resources.

The consequence is that one has to go one level up manually in order to
authenticate against the outer realm.
Netscape 4 and IE (any) behave differently. I guess they transparantly apply the
given username/password for the outer realm in order to load the linked recources.

To me, this makes total sense.
(Reporter)

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 54349 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
QA Contact: tever → junruh
You need to log in before you can comment on or make changes to this bug.