Please delete all *scl1* records from Inventory

RESOLVED DUPLICATE of bug 904789

Status

Infrastructure & Operations Graveyard
WebOps: Inventory
RESOLVED DUPLICATE of bug 904789
4 years ago
2 years ago

People

(Reporter: dcurado, Assigned: uberj)

Tracking

Details

(Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/638] )

(Reporter)

Description

4 years ago
There are probably many many records in Inventory for things in scl1.
I could spend a long time manually deleting them via the web interface.

I believe there is a CLI utility to do direct SQL queries/actions on
the database.  

Can you do this for SCL1 please?

THanks,
Dave
(Assignee)

Comment 1

4 years ago
Dave,
Can you look through these search results and ack that its okay to delete ever item show?

https://inventory.mozilla.org/en-US/core/search/?search=scl1

Looping in :arr so she can also confirm all this stuff can be deleted too.
Flags: needinfo?(arich)
I think we need to conserve the decommissioned hardware entries for history (and some of it may still be in storage for all I know). We talked about this briefly in the final scl1 move meeting.
Flags: needinfo?(arich)
(Assignee)

Updated

4 years ago
Whiteboard: [kanban]
(Reporter)

Comment 3

4 years ago
OK, I guess we need to leave that stuff in place.
I would like to delete references to vlans and IP addresses though.
We'll want to re-use those resources elsewhere.

uberj: can you limit the search to vlans, IPs, and DNS entries?

Updated

4 years ago
Whiteboard: [kanban] → [kanban:https://kanbanize.com/ctrl_board/4/638]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 904789
Product: Infrastructure & Operations → Infrastructure & Operations Graveyard
You need to log in before you can comment on or make changes to this bug.