[Loop] When the user lost the internet connection during a video call, Loop client is not notified

RESOLVED DUPLICATE of bug 1067946

Status

Firefox OS
Gaia::Loop
RESOLVED DUPLICATE of bug 1067946
4 years ago
4 years ago

People

(Reporter: mbarone, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mobile app][blocking])

(Reporter)

Description

4 years ago
STR
1. Device A starts a call with device B
2. Device B answer with video ON
3. Device B lost the internet connection (i.e disable wifi)

ACTUAL RESULT
The call is terminated but both device remains in Loop client for few minutes with the time counter running. Finally the Loop feedback is showed in the device A. The device B doesn't exit from Loop.

EXPECTED RESULT
As per AC, the "Call terminated by a unknown reason (or the reason of the termination if it is known)" message should be displayed
(Reporter)

Comment 1

4 years ago
Device: Flame
Loop version: 08b040a
(Reporter)

Updated

4 years ago
Whiteboard: [mobile app]
This issue still occurs on the latest 2.0 build with the v165 KK base.  The user who remains connected to wifi will eventually exit without notification as to why the call ended.  The user who lost connection will remain in the loop app indefinitely.

Environmental Variables:
Device: Flame 2.0
BuildID: 20140819030000
Gaia: 287a2c725a5c14e5dc1d48e3158ffc79c7d1ea33
Gecko: 6329352ca531b977979451e77e5862af485388b2
Version: 32.0 (2.0) 
Firmware Version: v165
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Loop version: 32219a2
Whiteboard: [mobile app] → [mobile app][blocking]
Blocks: 1010713
Dependent US bug 1010713, updated, according to it the user will get notified "Call ended by a unknown reason (or the reason of the termination if it is known) and the call failed tone will be played (The app will wait for a timeout before showing this to user just to check this is not a momentary situation but it is a permanent failure)
After talking with Jose Antonio, Bug 1067946 will fix this issue, according to Product feedback the users will be notified about the failure with "Call failed"
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1067946
You need to log in before you can comment on or make changes to this bug.