Closed Bug 1045584 Opened 8 years ago Closed 8 years ago

Remove everything relating to frames from OldDebugAPI

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla34

People

(Reporter: evilpie, Assigned: evilpie)

References

Details

Attachments

(1 file)

Attached patch v1Splinter Review
I moved most of the code from OldDebugAPI that was still used by EvalInFrame to that function. I also removed the XPConnect function debugDumpEvalInJSStackFrame, if we still need that I could instead put the guts of EvalInFrame somewhere else so the implementation can be shared.
Attachment #8463964 - Flags: review?(jdemooij)
Attachment #8463964 - Flags: review?(bobbyholley)
Comment on attachment 8463964 [details] [diff] [review]
v1

Review of attachment 8463964 [details] [diff] [review]:
-----------------------------------------------------------------

\o/ Thanks for doing this!
Attachment #8463964 - Flags: review?(jdemooij) → review+
Comment on attachment 8463964 [details] [diff] [review]
v1

Review of attachment 8463964 [details] [diff] [review]:
-----------------------------------------------------------------

Hm, I never knew about DumpJSEval. It seems like it might have been pretty useful for debugging actually, but this code is pretty nasty. I think we could build a saner replacement if the need arises.
Attachment #8463964 - Flags: review?(bobbyholley) → review+
https://hg.mozilla.org/mozilla-central/rev/db9349e9fe14
Assignee: nobody → evilpies
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
You need to log in before you can comment on or make changes to this bug.