Closed Bug 1045621 Opened 9 years ago Closed 6 years ago

Firefox prompts to install Flash even though it is already installed

Categories

(Core Graveyard :: Plug-ins, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(firefox32 affected, firefox33 affected, firefox34 affected)

RESOLVED INCOMPLETE
Tracking Status
firefox32 --- affected
firefox33 --- affected
firefox34 --- affected

People

(Reporter: adalucinet, Unassigned)

Details

Reproducible on:
Firefox 32 Beta 2 (BuildID: 20140728123914):
Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0
the latest Aurora (BuildID: 20140729004006):
Mozilla/5.0 (X11; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0
the latest Nightly (BuildID: 20140729030202):
Mozilla/5.0 (X11; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0

Prerequisites: Flash plugin is installed.

STR:
1. Launch Firefox.
2. Navigate to https://marketplace.firefox.com/app/wgt-golf
3. Install and open the app

Expected results: The app is properly launched.

Actual results: The game is not opened. "Get Adobe Flash Player" message is displayed.

Notes:
1. Flash version 11.2.202.335 is installed. Also reproducible with Flash 11.2.202.297.
2. Not reproducible on Windows nor Mac OS X.
3. Not a recent regression - reproducible with FF 31 beta 9.
Hi, 

I experienced this as well, with the very same app, on Debian Linux x86_64 with Firefox 33.

It prompts me to install Flash even if I have it already installed. My Flash version is: 11.2.202.359.

Let me know if you need more information!

Cheers,
Francesca
Resolving old bugs which are likely not relevant any more, since NPAPI plugins are deprecated.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → INCOMPLETE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.