Search results differ after adding a comment to an app

RESOLVED WORKSFORME

Status

Marketplace
Reviewer Tools
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Madalin Cotetiu, Unassigned)

Tracking

Avenir
2014-07-29
x86_64
Windows 7
Points:
---

Details

(URL)

(Reporter)

Description

4 years ago
Steps to reproduce:
1. Open reviewer tools Queues-Apps: https://marketplace.allizom.org/reviewers/apps/queue/
2. Perform a search and make a note of the search results
3. Click on any of the apps returned and add a comment
4. Perform the same search made in step 2 

Expected results:
Both searches return the same apps.

Actual results:
The search results differ after making a comment

Notes/Issues
Verified in FF34 (Win7) Issue can be reproduced in stage and -dev
Screencast for this issue: http://screencast.com/t/WKMlSvTzHE
I suspect that your advanced search options were set to status=any as the list contains apps that have been deleted/rejected/published. The default is status=pending.

The form doesn't remember the advanced option settings between page refreshes so the list will default back to only the pending apps after a page reload.

I think this works as intended and nothing strange is going on.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.