Repo menu: Separate out repos for other projects (eg Thunderbird)

RESOLVED DUPLICATE of bug 1066377

Status

Tree Management
Treeherder
P5
normal
RESOLVED DUPLICATE of bug 1066377
4 years ago
7 months ago

People

(Reporter: emorley, Unassigned)

Tracking

(Blocks: 1 bug)

Details

(Reporter)

Description

4 years ago
Currently non-firefox repos are mixed in with the rest, eg:
* thunderbird-try
* thunderbird-esr24
* thunderbird-trunk

It would be good if we could separate these out.

I was initially going to suggest using the repo 'codebase' field, which is currently set to 'gecko' for firefox related repos, and '?' for thunderbird - but we could change the latter to {'comm', 'comm-central', 'thunderbird'} and use these names as mini headings for each project group in the repos menu.

However, these other projects perhaps don't have sufficient repos to warrant a structure like:

gecko:
  * development:
      ** mozilla-central
      ** mozilla-inbound
  * release-stabilisation:
      ** mozilla-aurora
  * try:
      ** try

thunderbird:
  * development:
      ** thunderbird-trunk
  * release-stabilisation:
      ** thunderbird-aurora
      ** thunderbird-beta
  * try:
      ** thunderbird-try

...so perhaps we should just add a new repo group called 'thunderbird' and put all of them under there?

Though if we do that, the thunderbird-try repo will not be in the repo group "try" so it makes it harder to special-case it for try repo only features. Unless we add another repo field "isTry:true" ?

Thoughts?
+1 to using the codebase field.
(Reporter)

Comment 2

4 years ago
An alternative to the repos menu layout suggested in comment 0, would be to have a grid (or something roughly equivalent) - with repo group on one axis and codebase on the other.

It might also be good if people can toggle on/off (or a section open/closed, depending on how we lay it out) certain codebases that are not of interest to them.
(Reporter)

Updated

4 years ago
Blocks: 1053985
(Reporter)

Updated

4 years ago
No longer blocks: 1030636
(Reporter)

Updated

3 years ago
Summary: Separate out repos for other projects (eg Thunderbird) on the repos menu → Repo menu: Separate out repos for other projects (eg Thunderbird)
(Reporter)

Updated

3 years ago
Blocks: 1125352
No longer blocks: 1053985
(Reporter)

Updated

3 years ago
Priority: P3 → P5

Updated

7 months ago
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1066377
You need to log in before you can comment on or make changes to this bug.