Closed Bug 1045805 Opened 5 years ago Closed 5 years ago

Rocket bar should show in expanded state when loading a new URL

Categories

(Firefox OS Graveyard :: Gaia::System::Browser Chrome, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
2.1 S3 (29aug)

People

(Reporter: djabber, Assigned: benfrancis)

References

Details

(Whiteboard: [systemsfe][p=2])

User Story

See UX spec at: https://mozilla.box.com/s/q6to371l3gk0zj0guqhv

Attachments

(1 file)

Bug raised on Vivien's WIP patch as per video in https://bugzilla.mozilla.org/show_bug.cgi?id=1039519 (comment 22)

Steps to reproduce:
1) Open a new browser window
2) Load a site and scroll down the page
3) Follow a link to another URL

Expected behavior: When loading the new URL, the Rocket bar should be in expanded state

Actual behavior: The rocket bar remains in collapsed state
Duplicate of this bug: 1053750
Blocks: 941182
No longer blocks: rocketbar-search-mvp
Attachment #8477489 - Flags: review?(kgrandon)
QA Contact: bfrancis
Whiteboard: [systemsfe][p=2]
Assignee: nobody → bfrancis
QA Contact: bfrancis
Target Milestone: 2.1 S1 (1aug) → 2.1 S3 (29aug)
Target Milestone: 2.1 S3 (29aug) → ---
Comment on attachment 8477489 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/23215

Looks good, thanks! It does jump a little bit while the old content is displayed which is a shame, we should see if we can clean this up a bit so it doesn't jump in the future. Maybe some tuning of the events is needed.
Attachment #8477489 - Flags: review?(kgrandon) → review+
In master: https://github.com/mozilla-b2g/gaia/commit/741f6c6f055f7b3ccbcb76992c9b61a1786f1595
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S3 (29aug)
You need to log in before you can comment on or make changes to this bug.