Closed Bug 1045971 Opened 10 years ago Closed 10 years ago

[e10s] HTTPS Everywhere addon's dropdown menu doesn't show list of enforced https sites or number of sites

Categories

(Firefox :: Extension Compatibility, defect)

34 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
e10s + ---

People

(Reporter: alreiten, Unassigned)

References

()

Details

(Keywords: addon-compat, dogfood)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:34.0) Gecko/20100101 Firefox/34.0 (Beta/Release)
Build ID: 20140729030202

Steps to reproduce:

STR:
Install HTTPS Everywhere, 5.0developement.0
Open E10 tab
Go to Bugzilla or any other site that HTTPS Everywhere has a Rule for
Go to the HTTPS Everywhere toolbar button, click to view drop-down


Actual results:

The HTTPS Everywhere button doesn't show the number of active Rules on the button or list them in the drop-down.


Expected results:

With Bugzilla, the addon icon should show that 1 Rule is active, listed as Mozilla in the drop-down.
alreiten, thanks for testing. I'll update our list of add-ons.
tracking-e10s: --- → +
Keywords: addon-compat
Yan: hi! \o

Allison: HTTPS Everywhere is using nsILoadContext.associatedWindow. Is that something you plan to shim (for SPDY Indicator bug 1041139?)

> NS_ERROR_UNEXPECTED: Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsILoadContext.associatedWindow] https-everywhere.js:430
Status: UNCONFIRMED → NEW
Component: Untriaged → Extension Compatibility
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86 → All
Summary: [e10s] HTTPS Everywhere addon doesn't show dropdown of enforced https sites or number of sites → [e10s] HTTPS Everywhere addon's dropdown menu doesn't show list of enforced https sites or number of sites
Jacob is the new maintainer of HTTPS Everywhere.
See Also: → 997808
IIRC, we managed to get the drop-down menu to show the applicable rules only for favicons and other requests that were visible to the Chrome process: https://github.com/diracdeltas/https-everywhere/tree/electrolysis.
I think this should be fixed by https://github.com/EFForg/https-everywhere/pull/526.
Keywords: dogfood
With the new 5.0developement.1 build of HTTPS Everywhere, this issue seems to be fixed.
\o/

Thanks for testing, alreitan. Works for me, too.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.