If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

visiting php.net causes tabbar to be obscured (layout.css.devPixelsPerPx not an integer & menubar hidden)

RESOLVED DUPLICATE of bug 1041530

Status

()

Core
Graphics: Layers
RESOLVED DUPLICATE of bug 1041530
3 years ago
3 years ago

People

(Reporter: henryfhchan, Unassigned)

Tracking

({regression})

Trunk
x86_64
Windows 8.1
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8464462 [details]
Illustration of bug.

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.125 Safari/537.36

Steps to reproduce:

Visit php.net (HWA on)


Actual results:

A black box appears in the tabbar.  Opening new tabs with URI php.net shows the same bug.  Switching to other tabs causes the area to become normal again.  Switching back shows the box again.
(Reporter)

Comment 1

3 years ago
Occurs even with HWA off. All add-ons disabled.
(Reporter)

Comment 2

3 years ago
Showing the Menu Bar fixes the problem for as long as the menu bar is shown.
(Reporter)

Comment 3

3 years ago
If I set #navigation-toolbar to a height that is larger to the current height (>=88px) (via DOM Inspector), the box disappears.
Keywords: regression
(Reporter)

Comment 4

3 years ago
If I choose Page Style > No Style, the issue disappears.
(Reporter)

Updated

3 years ago
Summary: visiting php.net causes back bar to appear when layout.css.devPixelsPerPx not an integer → visiting php.net causes tabbar to be obscured (layout.css.devPixelsPerPx not an integer & menubar hidden)
(Reporter)

Comment 5

3 years ago
Disabling either

> .navbar { background:#8892BF }

or

>.navbar-fixed-top { transform: translateZ(0px) }

at http://php.net/cached.php?t=1401249623&f=/styles/theme-medium.css
fixes the problem.  Layer rendering bug?
(Reporter)

Updated

3 years ago
(Reporter)

Comment 6

3 years ago
Testcase above.
The black box is actually the DWM Client Area.  For some reason, a height of 46px or more for inner div triggers the bug, less than 45px doesn't.  Also, the required width of the outer div varies with the width of the browser window i.e. if the browser window is narrow, the required width to reproduce may be 99%, while if browser window cover the whole screen, the required width to reproduce is just 95%.
(Reporter)

Comment 7

3 years ago
testcase 2:
data:text/html;charset=utf-8;base64,PCFkb2N0eXBlIGh0bWw+PG1ldGEgY2hhcnNldD11dGYtOD48Ym9keSBzdHlsZT0ibWFyZ2luOjAiPjxkaXYgc3R5bGU9ImJhY2tncm91bmQ6I2YwMDt0cmFuc2Zvcm06dHJhbnNsYXRlWigwKSI+PGRpdiBzdHlsZT0iaGVpZ2h0OjQ2cHgiPmZvbzwvZGl2PjwvZGl2Pg==

Comment 8

3 years ago
Could bug 1045695 be related?
QA Whiteboard: [bugday-20140804]
Component: Untriaged → Graphics: Layers
Product: Firefox → Core

Comment 9

3 years ago
(In reply to henryfhchan from comment #5)
> Disabling either
> 
> > .navbar { background:#8892BF }
> 
> or
> 
> >.navbar-fixed-top { transform: translateZ(0px) }
> 
> at http://php.net/cached.php?t=1401249623&f=/styles/theme-medium.css
> fixes the problem.  Layer rendering bug?

What date's nightly did you use? I expect this is a dupe of bug 1042985 which was duped to bug 1041530 which should be fixed on more recent nightlies.
Flags: needinfo?(henry.fai.hang.chan)
(Reporter)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(henry.fai.hang.chan)
Resolution: --- → DUPLICATE
Duplicate of bug: 1041530
You need to log in before you can comment on or make changes to this bug.