If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Stop exposing layoutManager.currentLayout and rename currentModifiedLayout to it's place

RESOLVED DUPLICATE of bug 1047837

Status

Firefox OS
Gaia::Keyboard
RESOLVED DUPLICATE of bug 1047837
3 years ago
3 years ago

People

(Reporter: timdream, Assigned: timdream)

Tracking

unspecified
2.1 S4 (12sep)
x86
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [p=1])

I was going to include the patch of this bug in bug 1040598 but it's proven to be cosmetic and conflicts with various inflight patches, so I think this should be separate from bug 1040598 and land when we are ready.

The rationale behind this change is because the |currentLayout| is not actually the currentLayout -- the modified layout *is* the layout that should be used by rendering and state control etc.

I have already identified the last place that need to refer to |currentLayout| (needCandidatePanel) and change it's logic. With that currentLayout should be unexposed (not really, coz JavaScript prototype doesn't allow us to) to |_currentLayoutBase| and |currentModifiedLayout| will be renamed to |currentLayout|.
Depends on: 1035619, 1020779
WIP https://github.com/timdream/gaia/tree/keyboard-rename-layout
Depends on: 1040621
It probably make more sense if this lands after FL ... I don't think the inflow of the patches will slow down anytime soon before then and I don't want to risk FL quality.
Target Milestone: 2.1 S2 (15aug) → 2.1 S4 (12sep)
Ended up redo the patch in bug 1047837.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1047837
You need to log in before you can comment on or make changes to this bug.