Have a longer time window for users to view Terms of Service and Privacy Notice from the Loop panel

VERIFIED FIXED in Firefox 34

Status

P1
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: aryx, Assigned: standard8)

Tracking

unspecified
mozilla34
x86_64
Windows 8.1
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox34 verified)

Details

(Whiteboard: p=1 [privacy requirement for first release])

User Story

As a non-signed in user, I should see the ToS and Privacy Notice until I receive my first call.

Rough impl:

- Stop setting seenToS pref from the panel.
- Set it from the MozLoopService when it opens a chat window on incoming call.

Attachments

(1 attachment)

Firefox Nightly and Aurora 20140728 on Windows 8.1

Clicking on the Loop toolbar button for the first time, the user can seen the links to the Terms of Service and the Privacy Notice, but clicking the first one will open it and cause the panel to close. Reopening it doesn't show the links again.

Should these links be shown for longer, e.g. until Loop is used for the first time to make a call?
(Assignee)

Comment 1

4 years ago
RT or Darrin probably need to make the call here.
Flags: needinfo?(rtestard)
(In reply to Archaeopteryx [:aryx] from comment #0)
> Firefox Nightly and Aurora 20140728 on Windows 8.1
> 
> Clicking on the Loop toolbar button for the first time, the user can seen
> the links to the Terms of Service and the Privacy Notice, but clicking the
> first one will open it and cause the panel to close. Reopening it doesn't
> show the links again.
> 
> Should these links be shown for longer, e.g. until Loop is used for the
> first time to make a call?

That sounds like the best way forward - stop showing the ToS and privacy policy links when you ever have received an incoming call (even if you never replied or declined the call)

I needinfo Geoff for info here as he was part of the decision to implement it the way it was implemented. I suspect it won't be an issue from your standpoint Geoff given it means users get exposed to the links for a longer period of time (until they receive a call VS previous decision to only expose the links the first time the panel was brought down) ?
Flags: needinfo?(rtestard) → needinfo?(gpiper)

Comment 3

4 years ago
I feel like we have been down this road before, but to summarize for early release channels for non-Firefox account holders, for both the initiator of a call and the receiver of a call, no matter how the call is started or received, for the first time both the initiator and receiver uses this service but not thereafter because they would have seen it the first time, we are to display in the UX window (as Darrin has done already and is implemented but without the links working to date), the Legal copy "By using this product, you agree to the Terms of Use [LINK] and Privacy Notice [LINK]."

Am I missing something? What is new here and why is there an issue?

The real question here relates back to the other bugs (specifically https://bugzilla.mozilla.org/show_bug.cgi?id=1044411) of getting the TOS URL identified, linked and live to the users.
Flags: needinfo?(gpiper)

Updated

4 years ago
Assignee: nobody → gpiper
(In reply to Geoff Piper from comment #3)
> I feel like we have been down this road before, but to summarize for early
> release channels for non-Firefox account holders, for both the initiator of
> a call and the receiver of a call, no matter how the call is started or
> received, for the first time both the initiator and receiver uses this
> service but not thereafter because they would have seen it the first time,
> we are to display in the UX window (as Darrin has done already and is
> implemented but without the links working to date), the Legal copy "By using
> this product, you agree to the Terms of Use [LINK] and Privacy Notice
> [LINK]."
> 
> Am I missing something? What is new here and why is there an issue?
> 
> The real question here relates back to the other bugs (specifically
> https://bugzilla.mozilla.org/show_bug.cgi?id=1044411) of getting the TOS URL
> identified, linked and live to the users.

The issue is:
1 We display both links on FTU fine
2 On FTU if you click one of the links you get there fine although the panel closes as you get to the link destination
3 Therefore as a user you never have a chance to click the second link as you now can't see the links anymore

The solution proposed is to stop displaying the links after you receive your first incoming call (so you get a chance to click both links until you receive your first call) rather than stop displaying links after you opened and closed the panel.

Is that fine with you?
Flags: needinfo?(gpiper)

Comment 5

4 years ago
I believe this is fine. Is there a way I can see this live as a demo though (without having to set up a new Nightly profile etc.)? This was not my experience when I did my FTU experience.
Flags: needinfo?(gpiper)
The second link (privacy notice) is broken at the moment (bug 1034841). You can let Firefox the legal text again by opening about:config from the location bar and resetting the loop.seenToS preference.
(Assignee)

Updated

4 years ago
Priority: -- → P1
Target Milestone: --- → mozilla34
(Assignee)

Comment 7

4 years ago
(In reply to Archaeopteryx [:aryx] from comment #6)
> The second link (privacy notice) is broken at the moment (bug 1034841). You
> can let Firefox the legal text again by opening about:config from the
> location bar and resetting the loop.seenToS preference.

Geoff, you can try the current nightly with this, or do you want a version to try after the suggested change of comment 4?
Flags: needinfo?(gpiper)

Comment 8

4 years ago
I installed a new Nightly profile, and went through the initiation of a call for Hello! again...however, the Terms of Use do not link correctly to a dedicated URL for the Hello! specific terms of service (instead they link to here: https://accounts.firefox.com/legal/terms...which is for FxAccounts generally). 

I believe we need the dedicated URL to host the Hello! specific Nightly terms of use (which are located for now still in the same GitHub repo cited above).

The Privacy Notice link is correct now.
Flags: needinfo?(gpiper)
This looks to be a dup of Bug 1035846.  Please reopen if there is something different about this bug.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1035846
(Assignee)

Comment 10

4 years ago
(In reply to Maire Reavy [:mreavy] (Plz needinfo me) from comment #9)
> This looks to be a dup of Bug 1035846.  Please reopen if there is something
> different about this bug.

Yes, the discussion was around how long to display the links for. I've extracted it out into the user story and updated the description to reflect it better.
Assignee: gpiper → nobody
Status: RESOLVED → REOPENED
User Story: (updated)
Resolution: DUPLICATE → ---
Summary: Allow users to open Terms of Service and Privacy Notice from Loop popup panel → Have a longer time window for users to view Terms of Service and Privacy Notice from the Loop panel
RT -- Is this something that can be moved to Fx35 or do we need it for the first release (Fx34)?  Can you talk with Geoff and then advise?
Flags: needinfo?(rtestard)
Whiteboard: p=1
After a discussion with Geoff he confirmed this is a requirement from his standpoint, we can't release without this implemented.
Flags: needinfo?(rtestard)
Whiteboard: p=1 → p=1 [privacy requirement for first release]

Comment 13

4 years ago
(In reply to Romain Testard [:RT] from comment #12)
> After a discussion with Geoff he confirmed this is a requirement from his
> standpoint, we can't release without this implemented.

Correct
(Assignee)

Comment 14

4 years ago
Created attachment 8478182 [details] [diff] [review]
Have a longer time window for users to view Terms of Service and Privacy Notice from the Loop panel.

Simple patch to move the pref setting as described in the user story. This makes the ToS & Privacy notice stay up until the first incoming call is received.
Attachment #8478182 - Flags: review?(mhammond)
(Assignee)

Updated

4 years ago
Assignee: nobody → standard8
Status: REOPENED → ASSIGNED
Attachment #8478182 - Flags: review?(mhammond) → review+
https://hg.mozilla.org/mozilla-central/rev/851898432b6f
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Does this need manual testing or is testsuite coverage sufficient?
Flags: qe-verify?
Mark, can you please answer comment 17?
Flags: needinfo?(standard8)
(Assignee)

Comment 19

4 years ago
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #17)
> Does this need manual testing or is testsuite coverage sufficient?

Probably manual testing for now. This should verify that the ToS and privacy link are displayed on a fresh profile until a call is received.
Flags: needinfo?(standard8)
Flags: qe-verify? → qe-verify+
Sorry, this fell off my radar. I have now verified this is working as described in comment 19 using today's Aurora build.
Status: RESOLVED → VERIFIED
status-firefox34: --- → verified
QA Contact: anthony.s.hughes
You need to log in before you can comment on or make changes to this bug.