PNG images are not shown correctly

VERIFIED INVALID

Status

()

P3
major
VERIFIED INVALID
20 years ago
2 years ago

People

(Reporter: primorec, Assigned: pnunn)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

339.29 KB, application/octet-stream
Details
282.86 KB, application/octet-stream
Details
(Reporter)

Description

20 years ago
1) go to the http://www.cdrom.com/pub/png/png-MagnoliaAlpha.html with
   NETSCAPE4.61 and check the png image. Image is OK ( aka beatifull )
2) go to the same URL from above with mozillaM8 and the image is BAD
   Blue background of the image (sky) is wrong. Instead of being blue it
   uses a color and texture of the page itself.

I would like to mail to you two "screenshots", a GOOD one and a BAD one,
but I do not have your e-mail address. Please let me know where I can
mail two GIF files

Sincerely

Igor Furlan

Updated

20 years ago
Assignee: mjudge → pnunn
Component: Image Conversion Library → ImageLib

Comment 1

20 years ago
*** Bug 10461 has been marked as a duplicate of this bug. ***

Comment 2

20 years ago
[Moved to correct component.]

Comment 3

20 years ago
Instead of mailing the image, display this bug in bugzilla, press the "Create a
new attachment" link, and attach your screen shots to the bug. This way,
everyone can see the screen shot, not just Pam.

Comment 4

20 years ago
Pam, might this perhaps be a duplicate of 3013? (alpha channel not supported)
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → INVALID
(Assignee)

Comment 5

20 years ago
uh.
This isn't a bug. seriously.
The alpha channel means the textured background
should show through. Seeing the 'sky' background means
that alphachannel is not implemented.

Alphachannel is implemented with a _THRESH HOLD_.
I have a full 8bit (graduated) alpha channel implementation
on windows for non scaled images. I don't want to check it
in until I find out why the scaled images are going wrong.

-pn
(Reporter)

Comment 6

20 years ago
Created attachment 1016 [details]
PNG file seen by Mozilla M8
(Reporter)

Comment 7

20 years ago
Created attachment 1017 [details]
PNG file seen by netscape461

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 8

20 years ago
Verified Invalid per pnunn.
You need to log in before you can comment on or make changes to this bug.