Closed Bug 1046270 Opened 5 years ago Closed 5 years ago

decodeAudioData() sometimes fail to decode

Categories

(Core :: Web Audio, defect)

31 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1056032

People

(Reporter: steely.wing, Unassigned)

References

()

Details

(Keywords: testcase)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

- go to https://translate.google.com/?hl=zh-TW#en/zh-TW/firefox
- run this js in google translate page console
  https://gist.githubusercontent.com/steelywing/81a458baedaea3638661/raw/1134a554744e5fe96515608158943f5062bee93c/firefox.js

but if I
- go to https://translate.google.com/translate_tts?ie=UTF-8&q=firefox&tl=en&total=1&idx=0&textlen=7&client=t&prev=input
- run the js, it works


Actual results:

The buffer passed to decodeAudioData contains invalid content which cannot be decoded successfully.


Expected results:

decodeAudioData() success
if I run open once the audio (https://translate.google.com/translate_tts?ie=UTF-8&q=firefox&tl=en&total=1&idx=0&textlen=7&client=t&prev=input), and then I go to to google translate page (https://translate.google.com/), the js will works too.
That run properly before FF v29 and Chrome.
Summary: decodeAudioData() sometimes can't decode → decodeAudioData() sometimes fail to decode
I created a reproduce page, included reproducing step, this is same as the google page way, but more clearly.
http://steelywing.iblogger.org/firefox/webaudio.html

Please help =(
Your webaudio.html page works for me with linux64 builds (they use gstreamer):
firefox-31.0.en-US.linux64
2014-08-03-03-02-03-mozilla-central-firefox-34.0a1.en-US.linux-x86_64
QA Whiteboard: [bugday-20140804]
Component: Untriaged → Web Audio
Keywords: testcase
Product: Firefox → Core
Tested and fail on Windows XP x86, FF 31 & FF 34 (2014-08-11)
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1056032
You need to log in before you can comment on or make changes to this bug.