Crash in StateFactory.fromJSONObject

RESOLVED DUPLICATE of bug 964854

Status

()

Firefox for Android
Android Sync
RESOLVED DUPLICATE of bug 964854
4 years ago
6 months ago

People

(Reporter: rnewman, Unassigned, Mentored)

Tracking

({crash})

Firefox 32
All
Android
crash
Points:
---

Firefox Tracking Flags

(firefox32 affected)

Details

(Whiteboard: [lang=java])

(Reporter)

Description

4 years ago
java.lang.RuntimeException: Unable to resume activity {org.mozilla.firefox_beta/org.mozilla.gecko.fxa.activities.FxAccountStatusActivity}: java.lang.IllegalStateException: could not get state
at android.app.ActivityThread.performResumeActivity(ActivityThread.java:2823)
at android.app.ActivityThread.handleResumeActivity(ActivityThread.java:2862)
at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2245)
at android.app.ActivityThread.access$600(ActivityThread.java:139)
at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1262)
at android.os.Handler.dispatchMessage(Handler.java:99)
at android.os.Looper.loop(Looper.java:156)
at android.app.ActivityThread.main(ActivityThread.java:4987)
at java.lang.reflect.Method.invokeNative(Native Method)
at java.lang.reflect.Method.invoke(Method.java:511)
at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:784)
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:551)
at dalvik.system.NativeStart.main(Native Method)
Caused by: java.lang.IllegalStateException: could not get state
at org.mozilla.gecko.fxa.authenticator.AndroidFxAccount.getState(AndroidFxAccount.java:490)
at org.mozilla.gecko.fxa.activities.FxAccountStatusFragment.refresh(FxAccountStatusFragment.java:386)
at org.mozilla.gecko.fxa.activities.FxAccountStatusFragment.refresh(FxAccountStatusFragment.java:341)
at org.mozilla.gecko.fxa.activities.FxAccountStatusActivity.onResume(FxAccountStatusActivity.java:82)
at android.app.Instrumentation.callActivityOnResume(Instrumentation.java:1236)
at android.app.Activity.performResume(Activity.java:4620)
at android.app.ActivityThread.performResumeActivity(ActivityThread.java:2807)
... 12 more
Caused by: java.lang.NullPointerException
at org.mozilla.gecko.sync.Utils.hex2Byte(Utils.java:163)
at org.mozilla.gecko.fxa.login.StateFactory.fromJSONObject(StateFactory.java:59)
at org.mozilla.gecko.fxa.authenticator.AndroidFxAccount.getState(AndroidFxAccount.java:488)
I'm going to call this a dupe of Bug 964854.  We theory remains that we are tickling bugs in Android's AccountManager {get,set}UserData cache, similar to those reported by http://stackoverflow.com/questions/10657658/accountmanager-getuserdata-returning-null-despite-it-being-set.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 964854

Updated

6 months ago
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.