The default bug view has changed. See this FAQ.

Pasting URL into "about:blank" location field should replace "about:blank"

RESOLVED INVALID

Status

SeaMonkey
Location Bar
--
enhancement
RESOLVED INVALID
16 years ago
9 years ago

People

(Reporter: Josh Sled, Assigned: Joe Hewitt (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Especially under X, it's a pain to have selected a URL from some other window,
paste it into the location bar, go back to the beginning of the URL, carefully
select "about:blank" and delete it.

Comment 1

16 years ago
Personally i'd like to see it overpaste anyting in urlbar - or a feature to
quickly wipe urlbar clean with one click. Whether that be about:blank or some
other text.

On a related note: I filed bug 103329 regarding about:blank displaying in new
tabs. (It shouldn't appear there at all on Ctrl+t)

Comment 2

16 years ago
can't find exact dups - resolving as new. This is a usability issue regarding
the URL-bar and pasting on linux that i'd like to see implemented.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

16 years ago
WRT the overpaste _anything_, that won't work, especially for long URLs that get
wrapped [perhaps by *ahem*Exchange*ahem* IMAP servers that reformat mail], thus
requiring multiple pastes to have a complete URL.

WRT the about:blank not appearing on new tabs: I disagree.  Whatever happens in
the browser normally [read: w/o tabs] should happen per-tab as well...

Perhaps the "Blank page" pref really means: "blank page and empty location bar",
thus making this a non-issue...?

Comment 4

16 years ago
exactly: whatever happens normally should happen in tabs as well.
And when i open a new window, it's blank, and no "about:blank" is written in
URL-field.

Updated

16 years ago
Target Milestone: --- → Future

Comment 5

16 years ago
reassigning url bar bugs to default owner.
Assignee: blakeross → hewitt
Target Milestone: Future → M1

Updated

16 years ago
Target Milestone: M1 → ---
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 6

15 years ago
about:blank was removed on open, because people didn't wanna add an extra step
in deleting the about:blank before typing.

Comment 7

15 years ago
This bug reappeared in the newest builds (my build is 2002041722 for Solaris
2.6). When a new tab is opened the url bar contains about:blank. It should be
empty so that a URL could be pasted there.

Comment 8

15 years ago
confirm on
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2a) Gecko/20020911 MultiZilla/v1.1.22
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826

It's still here 

Comment 9

14 years ago
about:blank should be hidden, so fixing this shouldn't be necessary.  It's
hidden on new tab for me in Seamonkey and Firebird now.

Comment 10

11 years ago
Yes, the only way you should be able to get about:blank into the URL bar now is to type it yourself.

resolving INVALID since the reported problem is no longer relevant
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.