Closed Bug 1046516 Opened 6 years ago Closed 5 years ago

[Flame][NFC] check HCI_EVENT_TRANSACTION behavior in suspend mode

Categories

(Firefox OS Graveyard :: Vendcom, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.1+)

RESOLVED DUPLICATE of bug 1085305
2.1 S2 (15aug)
blocking-b2g 2.1+

People

(Reporter: dimi, Assigned: dimi)

References

Details

Attachments

(1 file)

The HCI_EVENT_TRANSACTION should be notified even when device is in suspend mode.
So when user back to normal state it could see the notification of a complete tranbsaction
Some status update.
Currently when flame enter suspend mode, then card emulation won't work. card reader could not detect nfc device in this case.
Test V123 with replaced nfcd(to enable CE mode) card emulation mode won't work either.
Need vendor's help to check this
Flags: needinfo?(whuang)
Flags: needinfo?(frlee)
Flags: needinfo?(frlee) → needinfo?(youlong.jiang)
Blocks: 979152
Flags: needinfo?(whuang)
We need to fix this bug during stabilization. But I don't see this belong to any acceptance criteria of user story, bug 979152. If I am wrong, please add this bug back to blocker of bug 979152.
No longer blocks: 979152
blocking-b2g: --- → 2.1+
Component: NFC → Vendcom
Hi Francis, do we have any update from partner about this bug ? Does flame-kk release fix this issue ?
Attached file v123 & v162 log.tar.gz
ping.
Flags: needinfo?(frlee)
i have loop vincent, Dimi, etc in a mail loop yesterday, T2M is checking logs and will feedback once they have solution.
Flags: needinfo?(frlee)
hi all -

we've checked logs and found there isn't obvious difference in kernel level log between v123 and v162. now pushing NXP to check hal level.

tks.
Flags: needinfo?(youlong.jiang)
Thanks, Youlong.
Did you get feedback from NXP already?
Flags: needinfo?(youlong.jiang)
Dimi,
Is this the one fixed by updating new "config"?
Flags: needinfo?(dlee)
(In reply to Wesley Huang [:wesley_huang] from comment #10)
> Dimi,
> Is this the one fixed by updating new "config"?

Hi Wesley,
No, i have tested again yesterday and it is not fixed. Have already noticed T2M and they are now checking this.
Flags: needinfo?(dlee)
QA Whiteboard: [COM=NFC]
Wesley, it is 2 weeks. Can you talk with T2M for this problem?
Flags: needinfo?(whuang)
Hi Wesly,
Would you mind giving Vincent a headup when the new build is ready for testing?
(Dimi is on PTO.)
Flags: needinfo?(wehuang)
This issue is included in the list that I'm following with T2M, per latest feedback it's fixed and will be included in the coming Flame KK release. (plan is T2M to release this SW on Sep./30 night).
Flags: needinfo?(wehuang)
update:
Just talked with Vincent and he will verify the new build shortly.
Flags: needinfo?(whuang) → needinfo?(vchang)
Thanks Wesley and Vincent, I just announced v184 SW which expect to fix this issue. Pls use it for test.
ok, I will try the new version tomorrow.
Flags: needinfo?(vchang)
I just tried v184 image today with Alison, but card emulation doesn't work. Card reader can't detect nfc device even if the device is not in the suspend mode.
Flags: needinfo?(wehuang)
Thanks Vincent's help, sad to hear this. I'll follow with T2M.

@Youlong, could you help double check in your side?
Flags: needinfo?(wehuang)
(In reply to Vincent Chang[:vchang] from comment #18)
> I just tried v184 image today with Alison, but card emulation doesn't work.
> Card reader can't detect nfc device even if the device is not in the suspend
> mode.
After checking again, we found that card emulation doesn't work due to the SIM card inserted at Flame SIM slot 2. Fired bug 1077343 to track this issue.
I tried this suspend mode issue based on v184, full flashing KK 2.1 latest build
Gaia-Rev        49f7b3f471e0345b719d92d6a3291c658b3ee4d8
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/b2f2db1efe4d
Build-ID        20141002160203
Version         34.0a2
Device          Flame

The symptom is "sometimes" card reader could detect device. Device suspend mode could not work as well as active mode since active mode could always be detected by card reader.
Dimi is taking PTO. Vincent is working on this.
Assignee: dlee → vchang
(In reply to Alison Shiue from comment #21)

> The symptom is "sometimes" card reader could detect device. Device suspend
> mode could not work as well as active mode since active mode could always be
> detected by card reader.

Hi Shiue:

Just to clarify if my understanding is correct, per your test with v184:

active mode: card read can "always" detect device (with NFC CE mode)
suspend mode: card read can "sometimes" detect device (with NFC CE mode)

right?
Flags: needinfo?(ashiue)
(In reply to Wesly Huang from comment #23)
> (In reply to Alison Shiue from comment #21)
> 
> > The symptom is "sometimes" card reader could detect device. Device suspend
> > mode could not work as well as active mode since active mode could always be
> > detected by card reader.
> 
> Hi Shiue:
> 
> Just to clarify if my understanding is correct, per your test with v184:
> 
> active mode: card read can "always" detect device (with NFC CE mode)
> suspend mode: card read can "sometimes" detect device (with NFC CE mode)
> 
> right?

Yes.
Flags: needinfo?(ashiue)
Thanks Alison, let me follow with T2M later this week when they are back from holiday.
(In reply to Alison Shiue from comment #24)
> (In reply to Wesly Huang from comment #23)
> > (In reply to Alison Shiue from comment #21)
> > 
> > > The symptom is "sometimes" card reader could detect device. Device suspend
> > > mode could not work as well as active mode since active mode could always be
> > > detected by card reader.
> > 
> > Hi Shiue:
> > 
> > Just to clarify if my understanding is correct, per your test with v184:
> > 
> > active mode: card read can "always" detect device (with NFC CE mode)
> > suspend mode: card read can "sometimes" detect device (with NFC CE mode)
> > 
> > right?
> 
> Yes.


hi -

I wanna to confirm that if just first time is ok after phone boot up. other any time can't work well?

tks.
Flags: needinfo?(youlong.jiang)
Hi Alison: would you help add more detail about your observation, for the fail case? as Youlong asked? Thank you.
Flags: needinfo?(ashiue)
Hi Youlong,

In fact, I cannot find the rule that when does the device can be detected in suspend mode.
After device waiting about 15 mins to go into suspend mode, card reader sometimes could detect device when the first time I put the device on card reader. Most of the time card reader could not detect device.
Flags: needinfo?(ashiue)
Assignee: vchang → dlee
I test v184 , Card emulation in suspend mode works fine. Also test v184 with latest GAIA and GECKO , it works too.
great, let's wait for next SW release with latest nfc files then get this issue closed :)
Alison, I think we can close this issue once you get verified
Flags: needinfo?(ashiue)
Dimi is still checking why Full Flash cannot work.
Flags: needinfo?(ashiue)
After checking with T2M, the root cause might related to unsync kernel image.
Hi Michael,

I think it's a good chance for us to update our kernel source.
Partner already update the kernel on:
https://github.com/t2m-foxfone/kernel_msm/tree/foxfone-one-v2.0

I can help if you think it's good to go :)
Flags: needinfo?(mwu)
Go ahead and update. Keeping ourselves up to date is always a good idea.
Flags: needinfo?(mwu)
Depends on: 1085305
Hi Dimi, can you help to check if the problem is fixed by bug 1085305?
I test latest PVT build and it works fine, we can close this bug now.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1085305
QA Whiteboard: [COM=NFC]
You need to log in before you can comment on or make changes to this bug.