js strict errors in tabbrowser.xml

RESOLVED DUPLICATE of bug 102184

Status

RESOLVED DUPLICATE of bug 102184
17 years ago
10 years ago

People

(Reporter: simmo, Assigned: simmo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
js strict errors in the following tabbrowser code:

Warning: redeclaration of var webProgress
Source File:
chrome://global/content/bindings/tabbrowser.xml#tabbrowser.updateCurrentBrowser()
Line: 27, Column: 18
Source Code:
              var webProgress = this.mCurrentBrowser.webProgress;

Warning: redeclaration of var webProgress
Source File:
chrome://global/content/bindings/tabbrowser.xml#tabbrowser.updateCurrentBrowser()
Line: 39, Column: 18
Source Code:
              var webProgress = this.mCurrentBrowser.webProgress;
(Assignee)

Comment 1

17 years ago
Created attachment 53444 [details] [diff] [review]
patch to fix
Reporter, all you had to do was query for "tabbrowser.xml" and you would have
found the original bug.

Secondly, if you take a bug, please CC the owner of the component.

Thirdly, if you make a patch for JS strict warnings make sure you get all of
them.  In the original, there seem to be more than you noticed.

Hate to mark a bug with a patch as a dupe, but you risk doing double work if you
don't search anyway.  Please query next time.

*** This bug has been marked as a duplicate of 102184 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.