Issues with live-updates map pulling from non-English google maps input

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: melissa, Unassigned)

Tracking

Details

(Whiteboard: [events])

(Reporter)

Description

4 years ago
There are some issues with the live-updates map showing events with addresses not written in English. E.g. I registered an event in Japan and wrote the address in Japanese, which showed up fine on maps.google.com. However, it did not show up on the live-updates map until I wrote the address in English. Thanks!
Depends on: 1020378
The total number of events shown on the page will at least be referenced no matter what locale events are in. However its not quite so simple to show events on the live-updates map. This can be solved with the resolution bug 1020378 and a small mod to take advantage of that in https://github.com/mozilla/makerparty-heatmap

Comment 2

4 years ago
Can you provide the equivalent english and japanese addresses?
(Reporter)

Comment 3

4 years ago
(Mozilla Japan office)
English: 7 Chome 5-6 Roppongi, Minato-ku, Tokyo, Japan 
Japanese: 〒106-0032 東京都港区六本木 7-5-6

Comment 4

4 years ago
Okay, it seems that google autocomplete works fine for "〒106-0032 東京都港区六本木". When you add 7 or 7-5, the address looks different from what you posted. When you add 7-5-6, the address doesn't autocomplete at all.

Looking at Japan's postal system, it's a valid way to write an address though. I'm not sure what to do here... is it possible to not write the 7-5-6 the shorthand way?
(Reporter)

Comment 5

4 years ago
No, that's the way addresses are typically written.  I noticed that with that address in particular, Google is wonky (but that's their problem).
As long as the city and country info can be pulled, it can go up on the map right?

Comment 6

4 years ago
The problem is that unless the address is autocompleted by Google we don't get latitude/longitude, city, or country information.
Should we maybe add some UI to manually ask for this information if we're not getting it back from Google? It means the data might be a little off but its better than nothing.

This can't be the only place where we don't get data back from Google either, so that might act as a reasonable fallback for when its failing us.

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.