youtube displays the browser context menu in e10s windows

VERIFIED FIXED in Firefox 34

Status

()

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jimm, Assigned: billm)

Tracking

Trunk
Firefox 34
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(e10s+, firefox34 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8465421 [details]
youtube.png

STR:

1) disable or uninstall flash (uninstall is best!)
2) open a new e10s window
3) visit youtube, view an html5 video
4) right click on the video

In non-e10s windows, we get the youtube menu, in e10s windows, we get the youtube and browser context menus.
Assignee: nobody → wmccloskey
tracking-e10s: ? → +
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1047675

Updated

4 years ago
Component: General → Menus
Created attachment 8477816 [details] [diff] [review]
contextmenu

Without e10s, we end up here:
http://mxr.mozilla.org/mozilla-central/source/content/xul/content/src/nsXULPopupListener.cpp#105

That code checks the defaultPrevented property on the event and also some other stuff. In e10s, the event is generated in the context process and there's no XUL for the popup listener to be attached to, so we never hit that code.

What it does for content seems to be pretty simple, so I just implemented it in a little JS.
Attachment #8477816 - Flags: review?(felipc)
Attachment #8477816 - Flags: review?(felipc) → review+
https://hg.mozilla.org/mozilla-central/rev/a50d9d53bdff
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 34
QA Whiteboard: [good first verify]

Comment 5

4 years ago
[bugday-20140910]

This bug is fixed in Aurora 34.0a2 (buildID 20140910004000). Please set status-firefox34 to verified for me ;)
Thanks kenkon :) Marking this as verified based on comment 5.
Status: RESOLVED → VERIFIED
status-firefox34: --- → verified
You need to log in before you can comment on or make changes to this bug.