[Dolphin][Monkey Test] FxOS hangs on E.ME page, and it cannot return to homescreen

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Everything.me
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: whsu, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8465455 [details]
E.ME_log20140731.log

* Description:
  This problem is caught by Monkey test.
  When we run Monkey test on Dolphin device, we sometimes found that it was easy to hang on E.ME page.
  Even we tap home button key, it still cannot return to homescreen.

  Attach the log and video:
  - Log: E.ME_log20140731.log
  - Video: WP_20140731_002.mp4

* Reproduction steps:
  - NA

* Expected result:
  FxOS still works as normal after we run monkey test(22 hours) on it.

* Actual result:
  FxOS hangs on E.ME page

* Build information:( v1.4 Dolphin)
 - Gaia      eb3b185325901d4c04e2d43eb58d90835213bea9
 - Gecko     ad07d35fc4f1e24f4a14b1430ab9e5b58400d488
 - BuildID   20140729113113
 - Version   30.0


Thanks!
(Reporter)

Comment 1

4 years ago
Created attachment 8465456 [details]
WP_20140724_001.mp4
(Reporter)

Comment 2

4 years ago
[Blocking Requested - why for this release]:
It might relate to memory management.
blocking-b2g: --- → 1.4?
william, the attached video is about Camera. Could you please upload the one for E.Me?
Flags: needinfo?(whsu)
Hi Evelyn, Could you please kindly find someone to investigate the bug? 
Thanks !
Flags: needinfo?(ehung)

Comment 5

4 years ago
Per offline discussion with William, I don't think it's a Gaia issue. The device ran out of memory, and it was busy on releasing memory. However, since it's caused by monkey, we can't do anything without the dead device. I've asked William to keep the device intact if it happens next time.
Flags: needinfo?(ehung)
(Reporter)

Comment 6

4 years ago
(In reply to Peipei Cheng from comment #3)
> william, the attached video is about Camera. Could you please upload the one
> for E.Me?

Thanks Peipei!
I uploaded the correct one.
Flags: needinfo?(whsu)
(Reporter)

Comment 7

4 years ago
Created attachment 8466214 [details]
WP_20140731_002.mp4
(Reporter)

Comment 8

4 years ago
(In reply to Evelyn Hung [:evelyn] from comment #5)
> Per offline discussion with William, I don't think it's a Gaia issue. The
> device ran out of memory, and it was busy on releasing memory. However,
> since it's caused by monkey, we can't do anything without the dead device.
> I've asked William to keep the device intact if it happens next time.

Thanks Evelyn.
Sorry. I restarted the device and cannot reproduce it now.
I would like to monitor this bug.
If Monkey test cannot catch it next week, I would like to close this bug.
Thanks.

--- Needinfo "whsu" to update this bug. ---
Flags: needinfo?(whsu)

Comment 9

4 years ago
Ni Danny to monitor this issue in monkey tests.
No crash with non-optimized build can be found after the weekend test in 8/2-8/3.
We are testing optimized again.
Flags: needinfo?(dliang)
(Reporter)

Comment 10

4 years ago
Remove NI:wshu since Monkey test has transferred to Danny and Danny is helping on it.
Flags: needinfo?(whsu)
minus for now according to comments.
William please update when you have new results.
blocking-b2g: 1.4? → -
(Reporter)

Comment 12

4 years ago
(In reply to Wayne Chang [:wchang] from comment #11)
> minus for now according to comments.
> William please update when you have new results.

Okay! I will discuss the bug with Denny since he is in charge of Dolphin monkey test.
Thanks!
Didn't meet this issue on 8/5 monkey test with 3 devices and optimize build, below are the results:
1. No b2g was killed
2. No any hang issue
3. There are two crashes on two devices, see https://bugzilla.mozilla.org/show_bug.cgi?id=1038047
Flags: needinfo?(dliang)
(Reporter)

Comment 14

4 years ago
Thanks Danny!

One week has passed, I would like to mark this bug as "WORKFORME".
Please reopen it if it happens again.
Thanks!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.