Closed Bug 1046836 Opened 8 years ago Closed 8 years ago

Missing the Swiss-french keyboard's layout

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

defect
Not set
normal

Tracking

(b2g-v2.1 fixed)

RESOLVED FIXED
Tracking Status
b2g-v2.1 --- fixed

People

(Reporter: igor, Assigned: igor)

References

Details

Attachments

(1 file, 2 obsolete files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0 Iceweasel/32.0 (Beta/Release)
Build ID: 20140725014928

Steps to reproduce:

I've just been trying to have a layout similar to the Swiss-french QWERTY layouts, but with the french dictionnary for correcting words when typing.


Actual results:

I can't find any.


Expected results:

I should have found one !
So I've added the missing layout to Gaia, and I'm on the way of a pull request...
Attached file The PR URL related to the bug 1046836 (obsolete) —
Attachment #8465554 - Flags: review?(rlu)
Attachment #8465554 - Flags: review?(dflanagan)
Comment on attachment 8465554 [details] [review]
The PR URL related to the bug 1046836

Igor: thank you for taking the initiative to create this keyboard layout. I'm setting r- because we have a one-commit per landing rule, so you'll need to squash your commits (I use git rebase -i master) before we could land this.

Rudy is more current with the keyboard code than I am, so he should probably weigh in on this, too.

Also: is there anything specifically Swiss about this layout? Or its it just a qwertz arrangement with a french autocorrect dictionary?  If so, maybe we shouldn't put "Swiss" in the label because there might be users in france who prefer a qwertz layout, for example.  

What we do want is to ensure that users who select the ch-fr locale get this keyboard by default. I forget where the configuration file for that is. Rudy: do we map directly from selected language to keyboard layout or is there a configuration file somewhere that should be updated to include this layout?

I'm adding a feedback request for Delphine since she does localization work on the keyboard.  Does this look good to you, Delphine?
Attachment #8465554 - Flags: review?(dflanagan)
Attachment #8465554 - Flags: review-
Attachment #8465554 - Flags: feedback?(lebedel.delphine)
So actually, I'm not in charge of keyboards for localization. I think this would rather be :arky from our team :)

That said, this is the link you're trying to find:https://github.com/mozilla-b2g/gaia/commits/master/build/config/keyboard-layouts.json

Also, just wanted to note that we don't have ch-fr locale on FirefoxOS, so users can't select it from FTE
Attachment #8465554 - Flags: feedback?(lebedel.delphine) → feedback?
Comment on attachment 8465554 [details] [review]
The PR URL related to the bug 1046836

1. First of all, I think the correct language code for this should be fr-CH, e.g. 
http://msdn.microsoft.com/zh-tw/library/ms533052%28v=vs.85%29.aspx

2. 
Since 'fr-CH' is not one of the locale we supports, so we don't need to add the keyboard into,
https://github.com/mozilla-b2g/gaia/commits/master/build/config/keyboard-layouts.json

--
The layout itself looks good to me, with some nits to be addressed.

Arky,

Do you know anyone who understands French and is based on Switzerland, could give feedback on this patch?
Thanks.
Attachment #8465554 - Flags: review?(rlu)
Attachment #8465554 - Flags: feedback?(hitmanarky)
Attachment #8465554 - Flags: feedback?
Comment on attachment 8465554 [details] [review]
The PR URL related to the bug 1046836

Yeah, IIRC Jean-Yves might know
Attachment #8465554 - Flags: feedback?(jypenator)
Hi everyone,

David :

>  we have a one-commit per landing rule, so you'll need to squash your commits (I use git rebase -i master) before we could land this.

Ok, I think that's because I first labelled the commit as I wanted, then read that It should have been labelled with the bug's ID, so I tried to git commit --amend... So I have to learn how to squash them, as you kindly suggested.

The question of the locales. In my Debian, the "Swiss-french" layout is labelled "fr_CH.utf8", but it's the locale too. I can't know if a fr_CH locale would be usefull for Gaia. I'm using it since December 2013 and the only thing I miss is some keys in the keyboard.

So the ch_fr keyboard is indeed the German one (QWERTY), with the french autocorrect dictonnary, but I also change sometimes the order of the alternatives, because in french, even in Switzerland, we don't use the same accent with the same frequency.

Sometimes, as in Ubuntu for instance, I find difficult to find the correct swiss-french layout, because it's called "German Swiss-french"... :) In Gnome 3, as in Debian Wheezy, it's called "Français (Suisse).

Thank everyone for your answers.

iGor
(In reply to Igor Milhit from comment #6)
> So the ch_fr keyboard is indeed the German one (QWERTY), with the french
> autocorrect dictionnary, but I also change sometimes the order of the
> alternatives, because in french, even in Switzerland, we don't use the same
> accent with the same frequency.
> 
I confirm. A look at the patch looked like it is ok. The only place we could bikeshed is the order of rare alternative indeed (like ñ is the only common used "accented n" in French, in loan words like 'El Niño'), but this is bikeshedding.

Really good work.
Attachment #8465554 - Flags: feedback?(jypenator) → feedback+
I agree for the alternatives of the "n". May I change the order to "ñńň" ?
Attachment #8465554 - Attachment is obsolete: true
Attachment #8465554 - Flags: feedback?(hitmanarky)
Attachment #8466899 - Flags: review?(rlu)
Attached file Patch V1
I created a new pull request to include only one commit from your patch.
Attachment #8466899 - Attachment is obsolete: true
Attachment #8466899 - Flags: review?(rlu)
Attachment #8467571 - Flags: review?(rlu)
Comment on attachment 8467571 [details] [review]
Patch V1

r=me.
Attachment #8467571 - Flags: review?(rlu) → review+
Landed to Gaia master,
https://github.com/mozilla-b2g/gaia/commit/024a0a7a500b531e1f38098fdcdd111d35202a50

--
Igor, thanks for your work!
Assignee: nobody → igor
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
@Rudy Lu : Thank you very much for you patience and help. I really appreciate this !
You need to log in before you can comment on or make changes to this bug.