Closed Bug 1046876 Opened 6 years ago Closed 6 years ago

"Cu is not defined" in NetworkGeolocationProvider.js

Categories

(Core :: DOM: Geolocation, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED FIXED
2.1 S1 (1aug)
blocking-b2g 2.0+
Tracking Status
b2g-v1.4 --- wontfix
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: gerard-majax, Assigned: aus)

Details

(Keywords: regression, Whiteboard: [systemsfe][p=1])

Attachments

(1 file)

While playing with my Nexus S running master in the train:

07-31 19:02:47.082  2910  2910 E GeckoConsole: [JavaScript Error: "Cu is not defined" {file: "jar:file:///system/b2g/omni.ja!/components/NetworkGeolocationProvider.js" line: 518}]
07-31 19:02:47.086  2910  2910 E GeckoConsole: [JavaScript Error: "Cu is not defined" {file: "jar:file:///system/b2g/omni.ja!/components/NetworkGeolocationProvider.js" line: 518}]
07-31 19:02:47.101  2910  2910 E GeckoConsole: [JavaScript Error: "Cu is not defined" {file: "jar:file:///system/b2g/omni.ja!/components/NetworkGeolocationProvider.js" line: 518}]
07-31 19:02:47.105  2910  2910 E GeckoConsole: [JavaScript Error: "Cu is not defined" {file: "jar:file:///system/b2g/omni.ja!/components/NetworkGeolocationProvider.js" line: 518}]
07-31 19:02:47.109  2910  2910 E GeckoConsole: [JavaScript Error: "Cu is not defined" {file: "jar:file:///system/b2g/omni.ja!/components/NetworkGeolocationProvider.js" line: 518}]
07-31 19:02:47.113  2910  2910 E GeckoConsole: [JavaScript Error: "Cu is not defined" {file: "jar:file:///system/b2g/omni.ja!/components/NetworkGeolocationProvider.js" line: 518}]
07-31 19:02:47.254  2910  2910 E GeckoConsole: [JavaScript Error: "Cu is not defined" {file: "jar:file:///system/b2g/omni.ja!/components/NetworkGeolocationProvider.js" line: 518}]
07-31 19:02:47.254  2910  2910 E GeckoConsole: [JavaScript Error: "Cu is not defined" {file: "jar:file:///system/b2g/omni.ja!/components/NetworkGeolocationProvider.js" line: 518}]
07-31 19:02:47.265  2910  2910 E GeckoConsole: [JavaScript Error: "Cu is not defined" {file: "jar:file:///system/b2g/omni.ja!/components/NetworkGeolocationProvider.js" line: 518}]
07-31 19:02:47.265  2910  2910 E GeckoConsole: [JavaScript Error: "Cu is not defined" {file: "jar:file:///system/b2g/omni.ja!/components/NetworkGeolocationProvider.js" line: 518}]
due to change in bug 1034301?
Flags: needinfo?(aus)
(In reply to Garvan Keeley [:garvank] from comment #1)
> due to change in bug 1034301?

Yup, looks like it. I swear there was other usage of Cu in there but I guess not. Do you guys want me to take this or were we just trying to determine what change introduced this?
Flags: needinfo?(aus)
Patch incoming...
Assignee: nobody → aus
Status: NEW → ASSIGNED
Whiteboard: [systemsfe][p=1]
Target Milestone: --- → 2.1 S1 (1aug)
Attachment #8465719 - Flags: review?(kchen)
Attachment #8465719 - Flags: review?(kchen) → review+
Comment on attachment 8465719 [details] [diff] [review]
Patch - v1 - Define 'Cu'

Approval Request Comment
[Feature/regressing bug #]: 1034301
[User impact if declined]: Original issue reported in 1034301 will persist.
[Describe test coverage new/current, TBPL]:
[Risks and why]: None.
[String/UUID change made/needed]: None.
Attachment #8465719 - Flags: approval-mozilla-aurora?
Commit (b2g-inbound): https://hg.mozilla.org/integration/b2g-inbound/rev/841bd5ad4ca7

Leave open until decision to land on aurora is complete.
Keywords: leave-open
[Blocking Requested - why for this release]:
blocking-b2g: 2.1? → 2.0?
zero risk patch.
blocking-b2g: 2.0? → 2.0+
Keywords: leave-open
Comment on attachment 8465719 [details] [diff] [review]
Patch - v1 - Define 'Cu'

2.0+ gets automatic aurora approval.
Attachment #8465719 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/841bd5ad4ca7
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.