Closed Bug 1046928 Opened 6 years ago Closed 6 years ago

Downloaded apps from marketplace fail to start (twitter, x-type...)

Categories

(Firefox OS Graveyard :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

(b2g-v2.0 unaffected, b2g-v2.1 verified)

VERIFIED FIXED
2.1 S1 (1aug)
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified

People

(Reporter: gwagner, Assigned: fabrice)

References

Details

(Keywords: regression, smoketest)

Setup: Latest nightly update on flame.

STR: Try to open previously installed twitter app

Logcat:
    V/GeckoNSS( 2134): Top of ssl3_HandleCertificate ss=0xa8ef5000 fd=-1455729792
    V/GeckoNSS( 2134): Top of ssl3_CleanupPeerCerts ss=0xa8ef5000
    V/GeckoNSS( 2134): ssl3_HandleCertificate ss=0xa8ef5000 fd=-1455729792 lastcert=0x0 c=0xaed9b810 c->next=0x0 c->cert=0xaed9c010
    V/GeckoNSS( 2134): ssl3_HandleCertificate returning ss=0xa8ef5000 fd=-1455729792 rv=0 peercertChain=0xaed9b810
    I/Gecko   ( 2134): IPDL protocol error: Handler for SetCookieString returned error code
    I/Gecko   ( 2134):
    I/Gecko   ( 2134): ###!!! [Parent][DispatchAsyncMessage] Error: Processing error: message was deserialized, but the handler returned false (indicating failure)
    I/Gecko   ( 2134):
    I/Gecko   ( 2134): [Parent 2134] WARNING: waitpid failed pid:2577 errno:10: file ../../../gecko/ipc/chromium/src/base/process_util_posix.cc, line 261
    I/Gecko   ( 2134):
    I/Gecko   ( 2134): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
Bug 1046919 disables updates until this is fixed.
Can we make sure this is not happening on 2.0?
Note that just installing eg. twitter on a current trunk exhibits the bug. I agree with disabling updates, but it's not directly update-related.
(In reply to Gregor Wagner [:gwagner] from comment #2)
> Can we make sure this is not happening on 2.0?

Whoa there! Let's not just go adding regression and regression window wanted haphazardly. We have to first determine that it IS a regression. 

Just the QA-Wanted tag for 'branch-checks' is the proper first step.
QA Contact: croesch
(In reply to Fabrice Desré [:fabrice] from comment #3)
> Note that just installing eg. twitter on a current trunk exhibits the bug. I
> agree with disabling updates, but it's not directly update-related.

We disabled updates because of other breakage including the camera and email apps not launching at all.
(In reply to Joshua Mitchell [:Joshua_M] from comment #4)
> (In reply to Gregor Wagner [:gwagner] from comment #2)
> > Can we make sure this is not happening on 2.0?
> 
> Whoa there! Let's not just go adding regression and regression window wanted
> haphazardly. We have to first determine that it IS a regression. 
> 
> Just the QA-Wanted tag for 'branch-checks' is the proper first step.

We need a regression window for trunk and we should do a branch check to make sure this is not happening on 2.0.
Are you saying we need to check first if this is a regression on trunk?
Yes - if this repro's in 2.0 and 1.4 (which the branch checks tell us) it will not be a regression and a regression window will not be available
It worked yesterday and its broken today.
This did not occur on today's 2.0.

Device: Flame 2.0
BuildID: 20140731000246
Gaia: f6702e2aab77ac144955b3cbc042483b1c5eefa7
Gecko: b87b3b927d3a
Base Image: V122

[Blocking Requested - why for this release]:
Smoketest blocker, bad regression.

Requesting window, possible dupe of bug 1046790
I did a local backout of bug 1042881 and that fixes the regression.
QA Contact: croesch
I backed out in https://hg.mozilla.org/integration/b2g-inbound/rev/bdd901635243 so I guess we can close this one.
Assignee: nobody → fabrice
Blocks: 1042881
Status: NEW → RESOLVED
blocking-b2g: 2.0? → 2.1?
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S1 (1aug)
Possibly to land a test for this regression when bug 1042881 re-lands?
Flags: in-testsuite?
Fabrice can you check to see if the backout also fixes: bug 1046790 ?
Flags: needinfo?(fabrice)
(In reply to Peter Bylenga [:PBylenga] from comment #13)
> Fabrice can you check to see if the backout also fixes: bug 1046790 ?

I could not reproduce bug 104790 even before this backout.
Flags: needinfo?(fabrice)
blocking-b2g: 2.1? → ---
verified fixed


Environmental Variables:
Device: Flame Master
Build ID: 20140801085315
Gaia: 9689218473b6fc4dd927ad6aa7b06c05f0843824
Gecko: 44e5072476b7
Version: 34.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
Verified fixed on Flame 2.1 KK (319mb/full flash)

Actual result: Twitter launches.

Device: Flame 2.1
BuildID: 20141021001201
Gaia: e458f5804c0851eb4e93c9eb143fe044988cecda
Gecko: ee86921a986f
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
You need to log in before you can comment on or make changes to this bug.