Mozilla doesn't transfer downloaded StuffIt Archive file to Expander for postprocessingl.

VERIFIED WORKSFORME

Status

Core Graveyard
File Handling
VERIFIED WORKSFORME
17 years ago
2 years ago

People

(Reporter: Mark Leverson, Assigned: Steve Dagley)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I have:
500 mhz Indigo iMac, 384mb ram, OSX 10.1 and OS 9.2.1, 56K internal modem,
Earthlink dial up connection, Lexmark Z53 USB printer. Build 2001101117 OS 9 ver.

I started mozilla from OSX under classic. I tried to download a program from
http://download.cnet.com/. It downloaded the program fine. It didn't start the
helper app stuffit expander, just saved it to the desk top. Also mozilla didn't
import my helper app assignments from Netscape 4.7.8. It didn't even try to put
a new helper line in for the .hqx file extention, when I did the download. I
tried hitting the reset download prefs button in the prefs/navagator/helper apps
already.
Didn't you already report this as bug 104210?

*** This bug has been marked as a duplicate of 104210 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

17 years ago
I reported this on a different version and OS. I was using the OSX version of
0.9.4 and it does a similar thing. This also happens when Mozilla 0.9.5 is run
directly from OS 9.2.1. The Reset for file-opening prefs button doesn't work in
OS 9 Build 200110117. The reset button does work in OSX Build 2001091313.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

17 years ago
->apps File Handling
Assignee: asa → law
Component: Browser-General → File Handling
QA Contact: doronr → sairuh
->sdagley
Assignee: law → sdagley
(Assignee)

Updated

17 years ago
Assignee: sdagley → pchen
(Assignee)

Comment 6

17 years ago
Passing to pchen with the recommendation we WONTFIX any bug filed on the 8.x/9.x 
version of Mozilla when running under the Classic environment on OS X.  
Especially in bugs of this category as we already know there are issues related 
to AppleEvents used to drive the Finder which is a different beast in OS X.
(Reporter)

Comment 7

17 years ago
This problem occurs when running Mozilla 0.9.5 OS 9 ver. directly from OS 9.2.1.
This version also crashes when trying to manage bookmarks. The reset download
prefs button doesn't work in this vers.
(Reporter)

Comment 8

17 years ago
This problem occurs when running Mozilla 0.9.5 OS 9 ver. directly from OS 9.2.1.
This version also crashes when trying to manage bookmarks. The reset download
prefs button doesn't work in this vers.
is this still a problem with recent trunk bits?

Comment 10

17 years ago
Changing OS to Mac OS 9.x because reporter is talking about a regular Mozilla
Mac build rather than Fizzilla, irrespective of whether he's running it under
Classic or not.

Changing Summary to better reflect his report.

Reporter, you need to open a new bug for the second problem you reported, that
of Mozilla not importing helper application settings from 4.x. One issue per
bug, please.
Severity: major → normal
OS: MacOS X → Mac System 9.x
Summary: Stuffit doesn't start → Mozilla doesn't transfer downloaded StuffIt Archive file to Expander for postprocessingl.
hm, could this be related to [perhaps dup?] bug 74027?

Comment 12

17 years ago
Mac file download handling is problematic in general.

Comment 13

16 years ago
Mark, can you still reproduce this problem using Mozilla 0.9.6?
this bug is incredibly unclear...

1) Do you get a dialog asking whether to download or open?  Or does Mozilla just 
   bring up a filepicker to pick a file to save to?
2) Do you have a helper in Mozilla's helper app prefs for the mime type in
   question?
3) Do you have a helper in Internet Config for the mime type in question?
4) Do you have a helper in Mozilla's helper app prefs for the ".hqx" extension?
5) If IC does this, do you have a helper in IC for ".hqx"?
(Reporter)

Comment 15

16 years ago
Greg

I can't duplicate this bug with 0.9.6 using OS 9 or OSX.
(Assignee)

Comment 16

16 years ago
Based on Mark's last comment any objections to marking this WORKSFORME?
Assignee: pchen → sdagley

Comment 17

16 years ago
Can someone set this report to WFM please?

Comment 18

16 years ago
ok
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs.

reopen only if this bug is still a problem with a *recent trunk build*.

mail search string for bugspam: AchilleaMillefolium
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.