Closed Bug 1047126 Opened 7 years ago Closed 7 years ago

[User Story] Keyboard transition should not overlap the soft home key bar

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86
macOS
defect
Not set
normal

Tracking

(feature-b2g:2.1, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S2 (15aug)
feature-b2g 2.1
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: rmacdonald, Assigned: markus)

References

Details

(Whiteboard: [systemsfe][tako])

Attachments

(2 files)

46 bytes, text/x-github-pull-request
timdream
: review+
mikehenrty
: feedback+
Details | Review
1.77 MB, video/quicktime
Details
As Mozilla, I want the keyboard transition (and keyboard) to not overlap the soft home key bar.

Acceptance Criteria:
1) As the keyboard transitions into the view, it should not appear on top of the soft home key bar.
Attached file Github pull request
The fix increases the software home bar z-index to match the keyboard, please take a look.
Flags: needinfo?(rmacdonald)
Hi Markus...

Apologies as I'm having permission problems with my phone and will need to work with engineering next week to get them resolved. Monday is a holiday in Canada so it would likely be Tuesday at the earliest. 

To keep things moving, I'll NI Francis as may have better luck with the patch on his device, and, because he's based in the US, will be in the office on Monday.  

- Rob
Flags: needinfo?(fdjabri)
Attached video keyboard.MOV
Thanks Markus, this seems to be working well.
Flags: needinfo?(fdjabri)
Comment on attachment 8466172 [details] [review]
Github pull request

Hi Michael, please review.
Attachment #8466172 - Flags: review?(mhenretty)
I took a look at the video and this is the intended behaviour. Thanks!
Flags: needinfo?(rmacdonald)
Assignee: nobody → markus.nilsson
feature-b2g: --- → 2.1
Target Milestone: --- → 2.1 S2 (15aug)
Comment on attachment 8466172 [details] [review]
Github pull request

Patch looks good, and seems straightforward enough. I think Tim, being the system AND keyboard guy, would be good to review.
Attachment #8466172 - Flags: review?(timdream)
Attachment #8466172 - Flags: review?(mhenretty)
Attachment #8466172 - Flags: feedback+
Comment on attachment 8466172 [details] [review]
Github pull request

This patch is trivial but z-index is unfortunately not entirely testable, so we should get this landed and see what happened.
Attachment #8466172 - Flags: review?(timdream) → review+
master: https://github.com/mozilla-b2g/gaia/commit/19ed3c9e78eaf234cc08484bde6998ae21552ba5
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
The issue is verified fixed in Flame 2.1 and Flame 2.2:

Flame 2.1 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141007000203
Gaia: 7f738edf66b9298bceef8a4981d05d04fd04e540
Gecko: b9d04c58580a
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.2 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20141007040205
Gaia: 83de447d9ae9a59459d7a445f9348a254c661850
Gecko: 9ee9e193fc48
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

The keyboard opening and closing does not overlap the SHB.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.