Support for installing TB extensions directly from FF

RESOLVED DUPLICATE of bug 295462

Status

()

Toolkit
Add-ons Manager
RESOLVED DUPLICATE of bug 295462
3 years ago
a year ago

People

(Reporter: Patrick O'Keeffe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme?])

(Reporter)

Description

3 years ago
It can be a real hassle to install some TB extensions. Better support for installing TB extensions from FF is requested. 

Specifically: I want to install 'Thunderbird Chat Notification'. It does not show up when I search from within TB (bug 1046933). I can find it on addons.mozilla.org but the developer indicates a newer version is available and it hasn't been posted because it's still under review. When I follow the dev's link to the latest version, FF attempts to install the add-on but since FF is not TB, it fails. I have not yet found a way to download this xpi and so I have not found a way to install the latest version in TB. Why so difficult?

Best case scenario: instead of FF trying & failing to install this TB xpi, it asks me if I want to open it with TB, I agree, it downloads xpi to a temp file, and then opens it with TB.

Alternatively, FF could just let me download the xpi if it is not valid for FF. 

I've already tried editing mimeTypes.rdf such that xpi files are always downloaded, never opened in FF. Couldn't get it to work. Followed along at http://kb.mozillazine.org/MimeTypes.rdf

And unfortunately, xpi files don't follow the rules laid forth at http://kb.mozillazine.org/File_types_and_download_actions -- AFAICT users are never prompted for what to do, FF always tries to install an xpi.
(Reporter)

Comment 1

3 years ago
And yes, I could click the 'See all' link from within the TB add-on browser, then the 'Chat and IM' category. That gets me to the "current" version (e.g a workaround to bug 1046933). However, when I click the dev's link to the newer version from within TB, it opens in FF so.... not helpful.
(Reporter)

Comment 2

3 years ago
I see my alternative solution was proposed 8 years ago by Keno in bug 313468, comment 16. 

But even if you manage to save the xpi file, attempting to open it with TB just results in a new email with the xpi as an attachment. To install it, you must drag-n-drop AND the only place you can drop it is the left-hand background area of the 'Add-ons Manager' tab. Not exactly intuitive.

Comment 3

3 years ago
If you manage to download the xpi in some way, you can then install it in TB by going into the addon manager and behind the little management icon there is "Install from file" menuitem.
Component: Untriaged → Add-ons Manager
Product: Thunderbird → Toolkit
Version: 24 → unspecified

Updated

3 years ago
OS: Windows 7 → All
See Also: → bug 295462
Whiteboard: [dupeme?]

Updated

a year ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 295462
You need to log in before you can comment on or make changes to this bug.