Frequent segfaults : MessageChannel.cpp::OnChannelErrorFromLink() (line 1531)

RESOLVED INVALID

Status

()

Core
General
--
critical
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: arthur.carcano, Unassigned)

Tracking

({crash})

31 Branch
x86_64
All
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8465905 [details]
End of what I've logged.

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140722064054

Steps to reproduce:

Segfault seems random. I've been lauching with strace and finally logged one.


Actual results:

Segfault.

Updated

4 years ago
Severity: normal → critical
QA Whiteboard: [bugday-20140804]
Keywords: crash, stackwanted

Comment 1

4 years ago
I have the same issue. Firefox 31.0-1 crashes with this errormessage:

[6062] ###!!! ABORT: Aborting on channel error.: file /build/firefox/src/mozilla-release/ipc/glue/MessageChannel.cpp, line 1531
[6062] ###!!! ABORT: Aborting on channel error.: file /build/firefox/src/mozilla-release/ipc/glue/MessageChannel.cpp, line 1531
[1]    6001 segmentation fault  firefox

There are two cases when this happens:

1. On opening Gmail (i think when the chat tries to make sound?)
2. On Quizlet, trying to play audio. http://quizlet.com/help/how-does-audio-work-on-quizlet

For Quizlet its enough to open the audio-example link: http://a.s.quizlet.com/en.mp3?v=5&b=SWYgeW91IGNhbiBoZWFyIHRoaXMsIGF1ZGlvIGlzIG5vdCBiZWluZyBibG9ja2VkLg&s=LAhrMA-0

This brings firefox to a silent crash. And the only error you can read above.

I really love Firefox, but i should open Gmail and stuff. Seems thats a reason with the Audio-Api ?

Would be great to get help.


best regarsds
adrian

---
uname -a: Linux tabletop 3.15.8-1-ARCH #1 SMP PREEMPT Fri Aug 1 08:51:42 CEST 2014 x86_64 GNU/Linux
pacman -Ss firefox: extra/firefox 31.0-1 [Installiert]

Updated

4 years ago
Status: UNCONFIRMED → NEW
Component: Untriaged → IPC
Ever confirmed: true
Product: Firefox → Core
Summary: Frequent segfaults : MessageChannel.cpp, line 1531 → Frequent segfaults : MessageChannel.cpp::OnChannelErrorFromLink() (line 1531)

Updated

4 years ago
Duplicate of this bug: 1051567

Comment 3

4 years ago
Stack trace on Windows 6.3: bug 1051567 comment 0.
OS: Linux → All

Comment 4

4 years ago
Hi,

i tried to reproduce it on a Windows Xp-Machine with version 31.0 and it doesnt crash. So it seems to be unix/linux specific.

best regards
adrian

Comment 5

4 years ago
(In reply to adrian from comment #4)
> i tried to reproduce it on a Windows Xp-Machine with version 31.0 and it
> doesnt crash. So it seems to be unix/linux specific.

The duplicate is about Windows 8.1 / 6.3.

Comment 6

4 years ago
The stack from bug 1051567 appears at first glance different from this one. That is either a plugin or a content process which is aborting because of some IPC error.

In this case there may also be some kind of child abort, but this bug appears to be about Firefox itself crashing. In this case what we need is a stack of the main Firefox process crash. Normally you'd provide this just by submitting a crash report and linking it here, but it appears that some (many?) of you are not running mozilla.org builds. If you are doing a self-build or can get symbols from your distro, please provide a stack trace from your debugger.
Component: IPC → General
Flags: needinfo?(arthur.carcano)
Flags: needinfo?(addis.aden)

Comment 7

4 years ago
Hi,

32bit version runs perfectly fine. Its probably 64bit only.

@benjamin_smedberg When im later on my 64bit-computer i will try to debug or just try it with the mozilla build :) Currently i just use the version of my archlinux distro. No selfbuild.

best regards
adrian
Flags: needinfo?(addis.aden)

Comment 8

4 years ago
[flagged myself again] sorry
Flags: needinfo?(addis.aden)

Updated

4 years ago
See Also: → bug 1051567

Comment 9

4 years ago
Hi,

sorry that it takes some time to get to this bug again. The official Linux 64bit release from the website doesnt crash. It cant play the audio from quizlet (tells me that the file is corrupted, whats wrong) but it works.

Sorry i dont know how to get a stack trace ...

best regards
adrian
Flags: needinfo?(addis.aden)
(Reporter)

Comment 10

4 years ago
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #6)
> The stack from bug 1051567 appears at first glance different from this one.
> That is either a plugin or a content process which is aborting because of
> some IPC error.
> 
> In this case there may also be some kind of child abort, but this bug
> appears to be about Firefox itself crashing. In this case what we need is a
> stack of the main Firefox process crash. Normally you'd provide this just by
> submitting a crash report and linking it here, but it appears that some
> (many?) of you are not running mozilla.org builds. If you are doing a
> self-build or can get symbols from your distro, please provide a stack trace
> from your debugger.

Hi ! Sorry for the delay I was away from my desktop computer ! :)
I'm running the Archlinux build. I don't face crashes when on Quizzlet or Gmail as adrian but I'm willing to provide any help you need if you tell me what to do ! 

I've seen adrian reported the bug (here)[https://bugs.archlinux.org/task/41572?project=1&cat%5B0%5D=2&string=firefox] so Imay also add a message there.
(Reporter)

Comment 11

4 years ago
I've actually discovered that one of my RAM module was broken.  I've deactivated it, and haven't come across any more crash since, and I hence mark this report as invalid.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(arthur.carcano)
Resolution: --- → INVALID

Updated

4 years ago
Keywords: stackwanted
You need to log in before you can comment on or make changes to this bug.