[Ringtone]Volume inconsistency problem in create Ringtone screen

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
7 months ago

People

(Reporter: ankit93040, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [g+][LibGLA, Dev, B] )

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.125 Safari/537.36

Steps to reproduce:

1. Go to music
2. Play a file in maximum volume.
3. While playing the file, press share choose ringtone
4. In the Create Ringtone screen, press play/pause button twice or thrice. Listen the song sound. It is reduced from previous.
5. Press the close(x) button.


Actual results:

In the Create Ringtone screen, the sound decreases.

Once close button pressed, sound increases to previous max value.


Expected results:

In the Create Ringtone screen, the sound should remain the same. It shouldn't decrease.
(Reporter)

Updated

4 years ago
Whiteboard: [g+][LibGLA, Dev, B]
(Reporter)

Updated

4 years ago
Flags: needinfo?(squibblyflabbetydoo)
(Reporter)

Updated

4 years ago
Component: General → Gaia::Ringtones

Comment 1

4 years ago
That probably means they're on different audio channels. Looking at the code, this doesn't appear to be a regression, so we should probably just keep this in mind for when we start reworking the audio channel code.
Flags: needinfo?(squibblyflabbetydoo)
(Reporter)

Comment 2

4 years ago
Hi Jim

I would request you to please see this once again - 

Steps to reproduce:

1. Go to music
2. Play a file in volume = 1. observe the sound (alomost not able to hear).
3. While playing the file, press share choose ringtone.
4. In the Create Ringtone screen, press play/pause button once. Listen the song sound. Press the volume up/down button to make the volume = 1. Observe the sound (Able to hear).
5. Press the close(x) button.
After close button when you reach the music play screen the sound changes.

There should be consistency in sound on both the screen for volume = 1.

I put the logs for channel & volume too in system app(sound_manager.js). The channel & volume are giving correct result for both the screens.

I think this is a gecko issue therefore.

Please see it once again.

In create ringtone screen & in music play screen & create ringtone screen everywhere the channel remains - "content".

thanks!
Flags: needinfo?(squibblyflabbetydoo)

Comment 3

4 years ago
I'm aware of the bug you're talking about. However, I don't think it's a regression, and it's a pretty minor issue that may well go away when we rework the audio channel code, so I'm just going to keep this in mind and check on it once that's done.
Flags: needinfo?(squibblyflabbetydoo)

Comment 4

7 months ago
Firefox OS is not being worked on
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.