Closed Bug 1047227 Opened 7 years ago Closed 7 years ago

Lightning 3.3 no event cancellation button

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect)

Lightning 3.3
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: malcolmrmclean, Assigned: MakeMyDay)

References

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0 (Beta/Release)
Build ID: 20140722195627

Steps to reproduce:

Upgrade to latest Thunderbird 31 and Lightning 3.3 and received an event cancellation.
Even after disabling all other addons, the Delete button still does not appear, so this isn't a conflict with another addon.


Actual results:

No Delete button appears to remove event from calendar as with Thunderbird 26 and Lightning 2.6.x. Buttons for new events and updates display as expected, however event cancellations to not.


Expected results:

A Delete button should appear when receiving an event cancellation.
Version: unspecified → Lightning 3.1
Do you get any error messages in Tools > Error Console?
Version: Lightning 3.1 → Lightning 3.3
I can confirm this bug, experiencing the same problem.
No errors at all. Even had the console open when a new event cancellation came in and no errors.
Confirming. The fix is simple here - the button is simply aclled with the wrong identifier.

Requesting also an approval for backporting to all branches.
Assignee: nobody → makemyday
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8466632 - Flags: review?(philipp)
Attachment #8466632 - Flags: review?(philipp) → review+
Target Milestone: --- → 3.3.1
Philipp, what about also backporting to aurora and beta?
Keywords: checkin-needed
I can confirm that applying the patch locally on 3.3 brings the Delete button back on event cancellations.

Is there perhaps an eta on when 3.3.1 will be available?
Comment on attachment 8466632 [details] [diff] [review]
FixDeleteInvitationButton-V1.diff

Review of attachment 8466632 [details] [diff] [review]:
-----------------------------------------------------------------

Oh yes, the approvals. Here you go. 


3.3.1 release should be (3.3 release date + ( n * 6 weeks) + a few days) where n depends on the number of patches that accumulate and the severity of the already applied patches.
Attachment #8466632 - Flags: approval-calendar-release+
Attachment #8466632 - Flags: approval-calendar-beta+
Attachment #8466632 - Flags: approval-calendar-aurora+
Pushing so this can get picked up by the release builds:

https://hg.mozilla.org/releases/comm-esr31/rev/d5d90baf34ec
Duplicate of this bug: 1063478
https://hg.mozilla.org/comm-central/rev/5e34658ee5c0
https://hg.mozilla.org/releases/comm-aurora/rev/3a73a2988e74
https://hg.mozilla.org/releases/comm-beta/rev/b74b11923934

This patch will not be in 3.4, but given its not a major release and the cycle is long gone, I'm not going to fix it there.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.