Closed Bug 1047384 Opened 8 years ago Closed 7 years ago

[sr] Search engine setup for Firefox Mobile for Serbian.

Categories

(Mozilla Localizations :: sr / Serbian, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: gueroJeff, Assigned: flod)

References

()

Details

(Keywords: productization)

Attachments

(1 file, 1 obsolete file)

We want to ship Firefox Mobile with a good list of search engines for Serbian. 

We're going to work towards this in three phases. First, the localization team and the l10n drivers will look at the market for the language and come up with a good set of search providers. Vanja, we'll need your input on this, the guidelines for making recommendations are on <hhttps://developer.mozilla.org/en-US/docs/Productization_guide>. 

For en-US, we currently use this set, to which we can fall back in the case of lacking localized alternatives:

> Google (mobile version), Yahoo, Bing, Amazon, Twitter, Wikipedia (slightly different to desktop, 32x32 icon)

We may also want to go with just a subset of the en-US engines, if that's more appropriate for the local market.

Once we decide to use a particular search engine (and we test it on a mobile device), l10n drivers will contact the owner and ask for permission, and for specifics like proper search flags. Vanja, we'll likely need your help to at least get the contact information.

For search engines that we already ship with on desktop and that you would like to include in mobile as well, the permission is not needed.  Consider using a mobile version of the engine if one is available.  Also, please make yourself familiar with instructions regarding the <Description/> element at <https://wiki.mozilla.org/L10n:Integrated_Search_Instructions>. For mobile, we'll want 64x64 size images, too.

Once we have a specification on what the search engines for Serbian should look like, flod (Francesco Lodolo) and the localization team will work on an implementation on that. flod will create and attach patches for the desired changes and get them reviewed. After a successful review, flod will land them. Vanja, if you're interested, you could create the patches, too. You'd ask flod for review on those before landing. 

Please don't commit any modifications in browser/searchplugins to the hg repository without a patch reviewed by flod, Stas, Axel or someone else appointed by the l10n drivers. The data here is sensitive to users and our search partners, thus the extra care here.

The Serbian team and flod will be driving this bug to completion.
I have talked with localization team and here is the list of search engines:
- Google
- Wikipedia-sr
- Bing
- Yahoo
- Twitter

CC'in the team.
I'll add Blogline to the list of feed handlers, since it's shipping on desktop.

I wonder about an ecommerce searchplugin: is Amazon popular in Serbia? Unfortunately we're having issues with eBay, so I'd keep it out of the possibilities for now.
Assignee: nobody → francesco.lodolo
Popularity of Amazon in Serbia is not that much like in the western countries, but there are a lot of people who use it, maybe even more than eBay, especialy photographes, so I would say yes, it is popular.
amazon.com or another European variant (e.g. "co.uk")?
Not sure about that, it depends from people to people. I personaly met some who have friends in Germany for example so they buy from .de, ship to their friend, and then he bring them here a package, but If you ask me, .com would be my choice.
Note to future myself: the current searchplugin for Wikipedia is broken, needs to be updated.
Blocks: fm-l10n-sr
Marko, could you confirm the list of plugins in Comment 1 please?
Flags: needinfo?(marko.andrejic93)
Attached patch bug1047384.patch (obsolete) — Splinter Review
This patch is based on the list in comment 1. In the meantime I fixed Wikipedia, and Bloglines is officially dead (the only alternative to Yahoo is NetVibes).
Yes, I can confirm them all and I would like to add DuckDuckGo if it is possible, as it is more and more popular, every day.
Flags: needinfo?(marko.andrejic93)
Updated patch with DDG. 

@Jeff
Want to give it a check?
Attachment #8738158 - Attachment is obsolete: true
Attachment #8738175 - Flags: review?(jbeatty)
Comment on attachment 8738175 [details] [diff] [review]
bug1047384v1.patch

lgtm. Thanks!
Attachment #8738175 - Flags: review?(jbeatty) → review+
You need to log in before you can comment on or make changes to this bug.