Lightning doesn't read or write calender alerts on CAL-DAV

RESOLVED INVALID

Status

RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: dominik, Unassigned)

Tracking

Lightning 3.3

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 2014060900

Steps to reproduce:

- Added a CalDAV Server (SOGO) to Lightning


Actual results:

- When I look at the appointments, lightning doesn't show the alert icon of appointments at appointments, that have alerts configured.
- When I edit such an appointment using lightning, the alert entry is dropped from the appointment
- When I edit another appointment, and try to set an alert via lightning, the alert isn't saved


Expected results:

- Alerts from the CalDAV calendar should be shown in lightning
- Lightning should not drop the alert from an appointment when saving
Could you enable calendar.debug.log and calendar.debug.log.verbose in the advanced config editor (Options > Advanced > General > Config Editor) and show us some logs about what is happening when you edit and event to add an alarm?

Also, what SOGo version and server URL are you using? Could it be that the server doesn't save the properties?
Flags: needinfo?(dominik)
(Reporter)

Comment 2

4 years ago
caldav url: https://sogo.f3l.de/SOGo/dav/dominik/Calendar/personal
sogo version: 2.2.8-1 (on debian)

The notification settings are correctly viewed and saved using the sogo webui or android (using the caldav-sync app and bussiness calendar).
(Reporter)

Comment 3

4 years ago
Log when adding a notification 5min before start of event FooBar:


CalDAV: send: BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:Europe/Berlin
X-LIC-LOCATION:Europe/Berlin
BEGIN:DAYLIGHT
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
TZNAME:CEST
DTSTART:19700329T020000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=3
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
TZNAME:CET
DTSTART:19701025T030000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=10
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20140918T112110Z
LAST-MODIFIED:20140928T140426Z
DTSTAMP:20140928T140426Z
UID:aa7974c3-f929-4ce0-95a0-e1ec0cf6f1a8
SUMMARY:FooBar
DTSTART;TZID=Europe/Berlin:20141009T150000
DTEND;TZID=Europe/Berlin:20141009T180000
CLASS:CONFIDENTIAL
TRANSP:OPAQUE
X-MOZ-GENERATION:1
BEGIN:VALARM
ACTION:DISPLAY
TRIGGER;VALUE=DURATION:-PT5M
DESCRIPTION:Mozilla Standardbeschreibung
END:VALARM
END:VEVENT
END:VCALENDAR

CalDAV: recv: 

CalDAV: Item modified successfully on Dominik SOGo

CalDAV: send(https://sogo.f3l.de/SOGo/dav/dominik/Calendar/personal/): <?xml version="1.0" encoding="UTF-8"?>
<C:calendar-multiget xmlns:D="DAV:" xmlns:C="urn:ietf:params:xml:ns:caldav"><D:prop><D:getetag/><C:calendar-data/></D:prop><D:href>/SOGo/dav/dominik/Calendar/personal/aa7974c3-f929-4ce0-95a0-e1ec0cf6f1a8.ics</D:href></C:calendar-multiget>

CalDAV: recv: 
<D:multistatus><D:response><D:href>/SOGo/dav/dominik/Calendar/personal/aa7974c3-f929-4ce0-95a0-e1ec0cf6f1a8.ics</D:href><D:propstat><D:prop><D:getetag>"gcs00000001"</D:getetag><C:calendar-data>BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:Europe/Berlin
X-LIC-LOCATION:Europe/Berlin
BEGIN:DAYLIGHT
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
TZNAME:CEST
DTSTART:19700329T020000
RRULE:FREQ=YEARLY;BYMONTH=3;BYDAY=-1SU
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
TZNAME:CET
DTSTART:19701025T030000
RRULE:FREQ=YEARLY;BYMONTH=10;BYDAY=-1SU
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20140918T112110Z
LAST-MODIFIED:20140928T140426Z
DTSTAMP:20140928T140426Z
UID:aa7974c3-f929-4ce0-95a0-e1ec0cf6f1a8
SUMMARY:FooBar
DTSTART;TZID=Europe/Berlin:20141009T150000
DTEND;TZID=Europe/Berlin:20141009T180000
CLASS:CONFIDENTIAL
TRANSP:OPAQUE
X-MOZ-GENERATION:1
END:VEVENT
END:VCALENDAR</C:calendar-data></D:prop><D:status>HTTP/1.1 200 OK</D:status></D:propstat></D:response></D:multistatus>

aChangeLogListener=undefined
calendarURI=https://sogo.f3l.de/SOGo/dav/dominik/Calendar/personal/ 
iscached=true
this.mQueuedQueries.length=0
Flags: needinfo?(dominik)
This looks very much like a server issue, as you can see the iCalendar data Lightning sends has a VALARM, but the data received from the SOGo server doesn't. Could you contact the SOGo folks instead? If this turns out to be a lightning bug feel free to reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.