Closed Bug 1047558 Opened 6 years ago Closed 6 years ago

"Firebug" add-on's "Inspect Element with Firebug" menu does not work with e10s

Categories

(Firefox :: Extension Compatibility, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
e10s + ---

People

(Reporter: karthikeyansgexecutives, Unassigned, Mentored)

References

Details

(Keywords: addon-compat)

Attachments

(1 file)

1. Install Firebug on Mozilla Firefox Nightly with "browser.tabs.remote.autostart"'s value TRUE
2. Open a web page (https://www.google.com/), right click on the element which you want to inspect and click on the "Inspect Element with Firebug". 
3. It will attach Firebug window to your browser at the bottom.

Expected Result:
HTML codes should be highlighted for inspected element

Actual Result:
No HTML or CSS are visible in the HTML editor and CSS Editor.
Depends on: 1047587
Blocks: e10s-addons
tracking-e10s: --- → ?
No longer depends on: 1047587
Keywords: addon-compat
Summary: "Firebug" add-on does not work with e10s → "Firebug" add-on's "Inspect Element with Firebug" menu does not work with e10s
With Nightly 35.0a1 (2014-09-11) and Firebug 2.0.4, the `Inspect Element with Firebug` context menu item does bring up Firebug, but there is no text content in the HTML view inside firebug.

The same thing happens when I use F12 to bring up Firebug.  No content in the HTML view in the Firebug window.

Firebug works as expected when I disable E10S.

...My intuition is that Firebug isn't "seeing" or "talking to" the tab at all.
Firebug 2 doesn't support e10s. You need to upgrade to Firebug 3 (currently in alpha phase)
See also:

http://blog.getfirebug.com/2014/11/10/firebug-3-next-generation-of-firebug/

Honza
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 1319414
You need to log in before you can comment on or make changes to this bug.