Enable http/2 (and alpn) by default

RESOLVED FIXED in mozilla34

Status

()

Core
Networking: HTTP
RESOLVED FIXED
3 years ago
7 months ago

People

(Reporter: nwgh, Assigned: nwgh)

Tracking

({dev-doc-needed})

Trunk
mozilla34
dev-doc-needed
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox34 affected, relnote-firefox 34+)

Details

(Whiteboard: [spdy] [http2release])

Attachments

(1 attachment, 2 obsolete attachments)

Now that we've gone WGLC, let's turn this sucker on to get some real interop testing!

This should probably only be on EARLY_BETA_OR_EARLIER
Created attachment 8466446 [details] [diff] [review]
patch
Attachment #8466446 - Flags: review?(mcmanus)
Created attachment 8466460 [details] [diff] [review]
patch

Now with less beta-ness
Attachment #8466446 - Attachment is obsolete: true
Attachment #8466446 - Flags: review?(mcmanus)
Attachment #8466460 - Flags: review?(mcmanus)
And yes, I will update the commit message before landing :)
https://tbpl.mozilla.org/?tree=Try&rev=6b5871d2e4d0 (just to make sure nothing goes crazy)
Depends on: 1046892
Comment on attachment 8466460 [details] [diff] [review]
patch

brave new world.

checking after (or with) h2-14.

and please don't have it hit a build until monday (so checkin on sunday at earliest) in case of badness.

awesome.
Attachment #8466460 - Flags: review?(mcmanus) → review+
Comment on attachment 8466460 [details] [diff] [review]
patch

we should get david's sign off on the alpn pref change..
Attachment #8466460 - Flags: review?(dkeeler)
Attachment #8466460 - Flags: review?(dkeeler) → review+
remote:   https://hg.mozilla.org/integration/mozilla-inbound/rev/72f85a52a2ca
https://hg.mozilla.org/mozilla-central/rev/72f85a52a2ca
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
[Tracking Requested - why for this release]:

Nicholas, so, this is a preference that will only turn on when Firefox 34 is in beta?  Is there anything in particular we should be aware of in QA for testing this - or just have a look at it when it goes to beta? Thanks!
QA Whiteboard: [qa+]
status-firefox34: --- → fixed
tracking-firefox34: --- → ?
Flags: needinfo?(hurley)
Depends on: 1049315

Comment 10

3 years ago
I'm running the 20140805 (rev https://hg.mozilla.org/mozilla-central/rev/7f81be7db528 ) nightly, yet "network.http.spdy.enabled.http2draft" is still set to false ?
(In reply to Peja Stija from comment #10)
> I'm running the 20140805 (rev
> https://hg.mozilla.org/mozilla-central/rev/7f81be7db528 ) nightly, yet
> "network.http.spdy.enabled.http2draft" is still set to false ?

self service: https://hg.mozilla.org/mozilla-central/file/7f81be7db528/modules/libpref/src/init/all.js#l1139
(In reply to Liz Henry :lizzard from comment #9)
> [Tracking Requested - why for this release]:
> 
> Nicholas, so, this is a preference that will only turn on when Firefox 34 is
> in beta?

no - this pref is simply on.

> Is there anything in particular we should be aware of in QA for
> testing this - or just have a look at it when it goes to beta? Thanks!

We'll be tracking interop opportunities - right now the only thing to be aware of are general regressions.

I'm  not sure why you marked this for tracking.
Flags: needinfo?(hurley)
(In reply to Peja Stija from comment #10)
> I'm running the 20140805 (rev
> https://hg.mozilla.org/mozilla-central/rev/7f81be7db528 ) nightly, yet
> "network.http.spdy.enabled.http2draft" is still set to false ?

That's one day too early. The newest nightly (20140806, rev 6cbdd4d523a7) is the one you want.

Updated

3 years ago
Depends on: 1050063
Backed out by request, for causing bug 1050063. Nightlies respun.

remote:   https://hg.mozilla.org/mozilla-central/rev/2f198e81ed98
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
status-firefox34: fixed → affected
tracking-firefox34: ? → ---
Created attachment 8469627 [details] [diff] [review]
checkin version of patch

Here's the version that has been checked in, and must be checked in again...
Attachment #8466460 - Attachment is obsolete: true
Attachment #8469627 - Flags: review+
Flags: needinfo?(kwierso)
Keywords: checkin-needed
Landed direct to m-c because it already landed just fine once except for the twitter issue:
https://hg.mozilla.org/mozilla-central/rev/bd44d84142e8
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Flags: needinfo?(kwierso)
Resolution: --- → FIXED
So, for the record, this WILL make tonight's Nightly build.
Keywords: checkin-needed
(In reply to Wes Kocher (:KWierso) from comment #17)
> So, for the record, this WILL make tonight's Nightly build.

thanks ;)

I feel like I'm in an on again off again relationship.

interestingly twitter has deployed a server side fix instead of rolling  back h2-14. Their implementation actually launched after this was enabled the first time. (perhaps before it hit the nightly build though - unsure on that.)

Updated

3 years ago
Depends on: 1059074
Depends on: 1059471
No longer depends on: 1059471

Comment 19

3 years ago
Release Note Request (optional, but appreciated)
[Why is this notable]: The next era in Web tech has begun. Seriously.
[Suggested wording]: Implemented HTTP/2 and APLN.
[Links (documentation, blog post, etc)]: :hurley might have a blog post?
relnote-firefox: --- → ?
(In reply to Florian Bender from comment #19)
> [Links (documentation, blog post, etc)]: :hurley might have a blog post?

I don't (yet), though I'm planning on writing one. Perhaps I should get on that :)
Florian, what is APLN? The thing that I found is this bug.

Nicholas, is this going to ship in 34? Thanks
Flags: needinfo?(hurley)
Flags: needinfo?(fb+mozdev)
(In reply to Sylvestre Ledru [:sylvestre] from comment #21)
> Florian, what is APLN? The thing that I found is this bug.
> 

alpn is a tls extension that allows negotiation of http/2.

> Nicholas, is this going to ship in 34? Thanks

http2-draft14 support will ship as part of 34. That's the same thing that IE announced in their developer preview this week.

Support for the final http/2 will follow when the IETF has decided the format is final. If that that turns out to be the same thing as http2-draft14 then we will probably just uplift the final "http2" label to channels that already have working http2-draft14 support. hth
OK. Thanks for the info.
So, since it is not a final standard, maybe we should write in the release note
Implementation of HTTP/2 (draft14) and APLN

Comment 24

3 years ago
I guess my ni? is covered by Comment 22, then :)
Flags: needinfo?(fb+mozdev)

Updated

3 years ago
Depends on: 1077806

Updated

3 years ago
See Also: → bug 1077806

Updated

3 years ago
See Also: bug 1077806
Flags: needinfo?(hurley)
Added to the release notes with "Implementation of HTTP/2 (draft14) and APLN" as wording.
A blog post or documentation would be appreciated!
relnote-firefox: ? → 34+
(In reply to Sylvestre Ledru [:sylvestre] from comment #25)
> Added to the release notes with "Implementation of HTTP/2 (draft14) and
> APLN" as wording.

typo - you want ALPN
Sorry. Fixed. thanks!
So looking at Firefox 34 Beta 10 (BuildID=20141117202603), I see the following preferences set by default:
network.http.spdy.enabled.http2draft = false
security.ssl.enable_alpn = true

Wasn't the http2 pref supposed to be true? Nicholas, am I missing something here?
Flags: needinfo?(hurley)
see bug 1088910 - we held back http2draft after early_beta on 34 to give the standards process a little more breathing room and server operators a little more chance to mature their -14 implementations if they choose to offer them.
Flags: needinfo?(hurley)
Thanks Patrick for clarifying this! Setting as "qe-verify-" since there doesn't seem to be anything for the QA team to do here.
QA Whiteboard: [qa+]
Flags: qe-verify-
Keywords: dev-doc-needed
Depends on: 1121706
Depends on: 1081613
Depends on: 1124561
No longer depends on: 1124561
You need to log in before you can comment on or make changes to this bug.