caret appears too quickly and inverts contents of wrong window

RESOLVED WORKSFORME

Status

Core Graveyard
GFX
--
minor
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Jesse Ruderman, Assigned: Kevin McCluskey (gone))

Tracking

Trunk
Future
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
1. Load http://bugzilla.mozilla.org/ in one browser window.
2. Load data:text/html,<body bgcolor="green"> in another Mozilla window.
3. Alt+tab between the two windows several times.

Result: when I switch from the green window to the bugzilla page, a *pink* 
caret appears (on top of the green background), and then the rest of the 
bugzilla page appears and the caret becomes black and starts blinking normally.

Expected: the bugzilla window should appear all at once, or at least in a more 
orderly fashion (only apply 'invert' to things in the same window, etc).

Note: it doesn't matter that the second window is a Mozilla window.  It could 
be an IE window with the same dark background.
(Assignee)

Comment 1

16 years ago
I can reproduce this. I would guess that the caret is doing a synchronous paint
which is causing it to appear before the background is painted.
Status: NEW → ASSIGNED
Target Milestone: --- → Future
Has things improved now with the fix for bug 287813?
(Reporter)

Comment 3

12 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060421 Minefield/3.0a1.  I don't know if it's because of the fix for bug 287813, or because I'm now using Windows XP and I'm now on a different computer, or what.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.