[B2G][2.0][Contacts][Flame 319MB] Wrong message is displayed when no contacts are available to import from Gmail / Outlook

RESOLVED DUPLICATE of bug 875159

Status

Firefox OS
Gaia::Contacts
RESOLVED DUPLICATE of bug 875159
4 years ago
4 years ago

People

(Reporter: RolandK, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 unaffected)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8466535 [details]
Screenshot

Description:
When the user has no Gmail contacts available to import, the user must be prompted with correct message "No contacts available to import".

Prerequiste: No contacts in Gmail 

Repro Steps:
1) Update Flame device to Build ID: 20140801000201
2) Connect to WiFi or enable cellular data
3) Launch Contacts > Settings
4) Click on Gmail button
5) Sign in with valid credentials to an account with zero contacts

Actual: Wrong message is displayed "All your friends are imported" 

Expected: Correct message is displayed to inform  the user, that there are no contacts available to import

Enviromental Variables:
Device: Flame 2.0 Mem 319MB
BuildID: 20140801000201
Gaia: 1d1a47a1135d8ce44db9b88db4d2ea6f454cf0a8
Gecko: e57d9f525233
Version: 32.0
Firmware: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Notes:
Repro frequency: 100%
Test Suite Name: Contacts
See attached: Screenshot
(Reporter)

Comment 1

4 years ago
This issue does occur on the 2.0 Mem 319MB Flame, 2.0 Mem 512MB Flame, 2.0 Buri, 1.4 Mem 319MB Flame, and 1.4 Buri builds:

Device: Flame 2.0 Mem 512MB
BuildID: 20140801000201
Gaia: 1d1a47a1135d8ce44db9b88db4d2ea6f454cf0a8
Gecko: e57d9f525233
Version: 32.0 (2.0)
Firmware: V122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Device: Buri 2.0
BuildID: 20140801000201
Gaia: 1d1a47a1135d8ce44db9b88db4d2ea6f454cf0a8
Gecko: e57d9f525233
Version: 32.0 (2.0)
Firmware: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Device: Flame 1.4 Mem 319MB
BuildID: 20140801000200
Gaia: 3feb37ee2ed2319c9e556728723a5517dc1663ea
Gecko: 2b5defe2d811
Version: 30.0 (1.4)
Firmware: V122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Device: Buri 1.4
BuildID: 20140801000200
Gaia: 3feb37ee2ed2319c9e556728723a5517dc1663ea
Gecko: 2b5defe2d811
Version: 30.0 (1.4)
Firmware: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

String reads "All your friends are imported"

This issue does not occur on the 2.1 Flame build:

Device: Flame 2.1
BuildID: 20140801040326
Gaia: 04ea7e1a4034a50d4a7a4f5b95a04a2ed8313908
Gecko: 104254bd1fc8
Version: 34.0a1 (2.1)
Firmware: V122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

String reads "No contacts avilable to import"
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v1.4: --- → affected
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → unaffected
Flags: needinfo?(ktucker)

Comment 2

4 years ago
I believe bug 875159 just needs to be uplifted.  It was only ever landed on master during the v2.1 development cycle in bug 875159 comment 25.
(In reply to Ben Kelly [:bkelly] from comment #2)
> I believe bug 875159 just needs to be uplifted.  It was only ever landed on
> master during the v2.1 development cycle in bug 875159 comment 25.

A bug with strings can *not* be uplifted at this point. 

Marking this back as a duplicate of bug 875159 (the alternative is WONTFIX).
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(ktucker)
Resolution: --- → DUPLICATE
Duplicate of bug: 875159

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
You need to log in before you can comment on or make changes to this bug.