Closed Bug 1047715 Opened 5 years ago Closed 5 years ago

suite's in-tree mozconfigs need changing to support Mock

Categories

(SeaMonkey :: Release Engineering, defect)

x86
Windows Vista
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ewong, Assigned: ewong)

References

Details

Attachments

(1 file, 3 obsolete files)

Currently, we use /tools/gcc-4.5/bin/g*.  Mock uses /tools/gcc-4.73-0moz1/g*.

Need to fix this before we can continue with bug 840427.
Attached patch bug_1047715.diff (obsolete) — Splinter Review
Attachment #8466546 - Flags: review?(bugspam.Callek)
Note: This for a post-push review.
(In reply to Edmund Wong (:ewong) from comment #2)
> Note: This for a post-push review.

And it will need to be pushed to c-a, c-b and c-r. (Currently working on c-c.)
Comment on attachment 8466546 [details] [diff] [review]
bug_1047715.diff

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: Mock requires these changes to build.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch: None.
Attachment #8466546 - Flags: approval-comm-release?
Attachment #8466546 - Flags: approval-comm-beta?
Attachment #8466546 - Flags: approval-comm-aurora?
Backed out the patch.
https://hg.mozilla.org/comm-central/rev/328d90cafea0

Reason: Wrong gcc version.
Attachment #8466546 - Attachment is obsolete: true
Attachment #8466546 - Flags: review?(bugspam.Callek)
Attachment #8466546 - Flags: approval-comm-release?
Attachment #8466546 - Flags: approval-comm-beta?
Attachment #8466546 - Flags: approval-comm-aurora?
Attachment #8466558 - Flags: review?(bugspam.Callek)
Comment on attachment 8466558 [details] [diff] [review]
suite mozconfig changes to support Mock (v2)

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: need this patch to build aurora and beta
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch: None
Attachment #8466558 - Flags: approval-comm-beta?
Attachment #8466558 - Flags: approval-comm-aurora?
Got Callek's approval (over irc). 

Pushed to comm-aurora:
https://hg.mozilla.org/releases/comm-aurora/rev/9ba16c7b3e4b
Comment on attachment 8466558 [details] [diff] [review]
suite mozconfig changes to support Mock (v2)

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: needs this patch to build c-r
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Attachment #8466558 - Flags: approval-comm-release?
Attachment #8466558 - Attachment is obsolete: true
Attachment #8466558 - Flags: review?(bugspam.Callek)
Attachment #8466558 - Flags: approval-comm-release?
Attachment #8466558 - Flags: approval-comm-beta?
Attachment #8466558 - Flags: approval-comm-aurora?
Attached patch suite patch (v4) (obsolete) — Splinter Review
This patch was taken from bug 1047999.  It fixes the build problems as it was pushed to c-b.  Now afaik, it should be pushed to c-c, c-a and c-r.
Attachment #8471219 - Flags: review?(bugspam.Callek)
Comment on attachment 8471219 [details] [diff] [review]
suite patch (v4)

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: needs these patches to build.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Attachment #8471219 - Flags: approval-comm-release?
Attachment #8471219 - Flags: approval-comm-aurora?
Landing for post-landing review/approval to c-a, c-r and c-c

a=Callek over irc.
Attached patch patch (v5)Splinter Review
Updated bitrotted patch for c-c, c-a.  

Going for post-landing review/approval.  (a=Callek over irc)

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined:  needs this to build on infra.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Attachment #8471331 - Flags: review?
Attachment #8471331 - Flags: approval-comm-release?
Attachment #8471331 - Flags: approval-comm-aurora?
Attachment #8471219 - Attachment is obsolete: true
Attachment #8471219 - Flags: review?(bugspam.Callek)
Attachment #8471219 - Flags: approval-comm-release?
Attachment #8471219 - Flags: approval-comm-aurora?
Attachment #8471331 - Flags: review? → review?(bugspam.Callek)
Comment on attachment 8471331 [details] [diff] [review]
patch (v5)

Review of attachment 8471331 [details] [diff] [review]:
-----------------------------------------------------------------

r+ and post-land a+
Attachment #8471331 - Flags: review?(bugspam.Callek)
Attachment #8471331 - Flags: review+
Attachment #8471331 - Flags: approval-comm-release?
Attachment #8471331 - Flags: approval-comm-release+
Attachment #8471331 - Flags: approval-comm-aurora?
Attachment #8471331 - Flags: approval-comm-aurora+
Marking this is as fixed since all trees have been patched.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Blocks: 1061336
You need to log in before you can comment on or make changes to this bug.