Error messages should clearly specify what fields they relate to

VERIFIED FIXED

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: krupa.mozbugs, Assigned: chuck)

Tracking

x86
Mac OS X
Points:
---

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8466553 [details]
screenshot

steps to reproduce:
1. Load https://marketplace-dev.allizom.org/curate/create/shelves
2. Enter all values except "Carrier" and "Region" and click Save

expected behavior:
Submission fails with error messages like "Carrier field is required" and "Region field is required"

actual behavior:
Submission fails with error messages "This field is required" and "This field is required" which is not very helpful. See screenshot.
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1047062
(Assignee)

Updated

4 years ago
Assignee: nobody → charmston
(Assignee)

Comment 2

4 years ago
https://github.com/mozilla/transonic/compare/7fd99c5264da...e539ea8b876d
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

4 years ago
verified fixed @ https://marketplace-dev.allizom.org/curate/create/shelves
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

4 years ago
Created attachment 8467275 [details]
postfix.png
You need to log in before you can comment on or make changes to this bug.