Closed Bug 1047780 Opened 8 years ago Closed 8 years ago

[e10s] crash in mozilla::layers::CompositorD3D11::DrawQuad(mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const&, mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const&, mozilla::layers::EffectChain const&, float, mozilla::gfx::Matrix4x4 const&)

Categories

(Core :: Graphics: Layers, defect)

34 Branch
x86
Windows 7
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 1043426
Tracking Status
firefox33 --- unaffected
firefox34 --- affected

People

(Reporter: alice0775, Unassigned)

References

()

Details

(Keywords: crash, regression)

Crash Data

[Tracking Requested - why for this release]: Regressed by Bug 1022612

This bug was filed from the Socorro interface and is 
report bp-a4492cef-4b15-4801-a758-c3dc82140802.
=============================================================

Steps To Reproduce:
1. Enable e10s autostart
2. Open http://www.mozilla.jp/about/mozilla/
3. Playback Video
4. Click Full Screen(全画面表示) Icon

Actual Results:
Browser crashes


Regression window(m-c)
Good:
https://hg.mozilla.org/mozilla-central/rev/e9cdcf646d1c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 ID:20140720153121
Bad:
https://hg.mozilla.org/mozilla-central/rev/4bafe35cfb65
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 ID:20140720181427
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e9cdcf646d1c&tochange=4bafe35cfb65


Regression window(m-i)
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9350909a3401
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 ID:20140719062420
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/24a69de91baa
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 ID:20140719065519
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9350909a3401&tochange=24a69de91baa

Regressed by: Bug 1022612


FYI, Build of Bug 1043426 Comment 12 does not fix this crash.
https://hg.mozilla.org/integration/mozilla-inbound/rev/fe28abfc3842
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140801065416
OS: Windows NT → Windows 7
Does not crash on Linux. I'll have to debug this at home.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1043426
No longer crash.
https://hg.mozilla.org/integration/mozilla-inbound/rev/1405060b0c96
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140804040427
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.