inbox lost after starting mail and compacting

VERIFIED WORKSFORME

Status

MailNews Core
Networking: POP
--
critical
VERIFIED WORKSFORME
17 years ago
9 years ago

People

(Reporter: marc oesch, Assigned: Navin Gupta)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
1. Starting mail
2. mail asks passwords to login for my 2 accounts
3. after entering passwords mail asks to compact folders ... accepting
4. when finished the inbox of my second mail account is empty all mails lost.

Remark: this bug was supposed to be resolved from version 0.9.3... still
happened now in version 0.9.4.
It is interesting to notice that I never lost the inbox of the first account it
was always the second account. (this happened now 3 times (2 times in version
0.9.3, once in 0.9.4))

IMPORTANT SUGGESTIONWould it be possible to place a copy of the original folder
somewhere before doing the compactation. (and delete this copy afterwards) This
would at least allow us to try and recover the mail folder if anything goes
wrong !!!!!!!
I tried to find a deleted inbox file somewhere on the disk but couldn't find one.

It is very annoying to loose important emails

Marc

Updated

17 years ago
QA Contact: esther → sheelar
This appears similar to this bug in the Debian BTS:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=114943&repeatmerged=yes

Comment 2

17 years ago
Reporter,
What is the build Id? Are both the accounts POP?  Navin had fixed some compact
bugs so just was wondering if you could be using the old builds which had some
problems.  
If they are pop folders which are local you can make a copy of these folders
from the explorer and put it somewhere else before you compact folders. 

Comment 3

17 years ago
Hi;

Have a look at http://bugs.debian.org/114943 where I've logged this in the
Debian BTS.  I've found a similar fault with 0.9.4.  In my case, I was just
compacting the one mailbox, but for some odd reason Mozilla exploded (it doesn't
do this often).

I agree with Marc - Mozilla should be more intelligent about how it compacts
folders.  A suggestion would be to leave the original folder intact, create a
new folder somewhere (/folder store/tmp/_rebuiltFolder or something), and only
replace the old folder once a successful compact was finished.  This is somewhat
wasteful on resources, and there are smarter ways of doing it, but it's probably
a reasonably quick hack (says the infrastructure guy who doesn't know C :).

Sheela: Regarding copying folders, absolutely, a backup would be a good idea. 
Any commercial installation will have one.  But since Mozilla can offer to
compact folders on a whim, and most POP users are not corporate users with nice
backup systems, it's not extremely practical to keep firing up a shell /
explorer / whatever to copy your folder store.  Not to mention also being
resource wasteful :)

My bug is related to Mozilla under Linux.  In an email from Robert Bihlmeyer he
suggests that this bug could be related to 70322, 85632, 102582, and/or 95964. 
The number of bugs indicates that this is a problem for people.

Cheers

Comment 4

16 years ago
same here!
it happened the first restart after adding the second POP account.
moz 0.9.5., build 2001101117 on Win2k

moz still asks me on every mail/news launch to compact all folders.
if I click yes it tries to compact the folders and kills at least one directory.
the mails in this directory are still accessible through a temporary folder
called tmp-something.
I even lost my filter rules! tmprules.dat was generated, but I couldn't restore
the filters from this folder.
so for now I just hit Now every time I'm launching mail/news...

Comment 5

16 years ago
marking this a dup of bug 95964 from the description of the problem. 
Assignee: sspitzer → naving
Component: Mail Window Front End → Networking - POP

Comment 6

16 years ago

*** This bug has been marked as a duplicate of 95964 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 7

16 years ago
Sheela, could you try reproducing this bug. I believe I fixed this long time back 
but something may have broken it. 
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 8

16 years ago
To the reporter of this bug:

Can you give the build id information?
Also the preferences you have checked for both the pop accounts?
What is the threshold size you have set in your prefs.[10kb, 20kb, 100kb]
Do you often work offline and then go back online and compact?
Have you renamed, moved or deleted your inbox folder prior to compaction in 
previous sessions?

I used a commercial trunk build from 2001-10-31-06 on win98. I am not able to 
reproduce this by following your steps. 
I think your steps are backwards.  If you have setup the threshold in prefs to 
compact folders and when it reaches the threshold the first time you start mail 
you will get the compact dlg first.  When you ok to the dlg then you are 
prompted with the password dlg for both the accounts if you have "check new mail 
 at start up" checked for both the accounts.

Please provide some more info to be able to reporduce this bug.

Comment 9

16 years ago
I am not able to reproduce this problem at all. Marking worksforme.  I use pop 
account everyday with daily builds and I auto compact as well manually compact 
folders and have not lost my inbox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME

Comment 10

16 years ago
verified as worksforme.  Reopen the bug if you have reproducible steps and 
occurs on the recent builds.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.