Closed Bug 1047945 Opened 5 years ago Closed 5 years ago

TileExpiry is leaked

Categories

(Core :: Graphics: Layers, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla34

People

(Reporter: khuey, Assigned: mattwoodrow)

References

Details

(Keywords: memory-leak, regression, Whiteboard: [MemShrink:P2])

Attachments

(1 file, 1 obsolete file)

TileExpiry is allocated and stored in a function local static variable.  It is never deleted, so it is leaked.
Assignee: nobody → jmuizelaar
Whiteboard: [MemShrink] → [MemShrink:P2]
Attached patch Don't leak TileExpiry (obsolete) — Splinter Review
Assignee: jmuizelaar → matt.woodrow
Attachment #8468799 - Flags: review?(jmuizelaar)
While you're poking around here would you mind adding a MOZ_OVERRIDE to that NotifyExpired?
Sure, done locally.
Comment on attachment 8468799 [details] [diff] [review]
Don't leak TileExpiry

Review of attachment 8468799 [details] [diff] [review]:
-----------------------------------------------------------------

Sure
Attachment #8468799 - Flags: review?(jmuizelaar) → review+
Can we land this?
Flags: needinfo?(matt.woodrow)
The old version crashes because we deleted sTileExpiry when it was still on the callstack.
Attachment #8468799 - Attachment is obsolete: true
Attachment #8474272 - Flags: review?(jmuizelaar)
Flags: needinfo?(matt.woodrow)
Attachment #8474272 - Flags: review?(jmuizelaar) → review?(bgirard)
Blocks: osx-tiling
Attachment #8474272 - Flags: review?(bgirard) → review+
https://hg.mozilla.org/mozilla-central/rev/1e22fe6f0462
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
You need to log in before you can comment on or make changes to this bug.