~/.thunderbird profile directories copied to another PC with rsync, I can see accounts, but cannot see the messages

VERIFIED WONTFIX

Status

Thunderbird
Folder and Message Lists
--
critical
VERIFIED WONTFIX
4 years ago
a year ago

People

(Reporter: jp willm, Unassigned)

Tracking

(Depends on: 1 bug)

31 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140715214327

Steps to reproduce:

backup of ~/.thunderbird and reuse this data on other PC's


Actual results:

On other PC with the same TB version 31 or older versions, I can no more see the messages after this ruse of the backup !



Expected results:

Normally, I reuse my main ~/thunderbird folder to synchronize my e-mail accounts on different PC's

It is a disaster !
(Reporter)

Updated

4 years ago
Severity: normal → critical
Keywords: crash
Priority: -- → P1
(Reporter)

Updated

4 years ago
Whiteboard: thunderbird restore backup failure

Comment 1

4 years ago
This worked in version 24?
Do you get a crash reporter dialog when you attempt to start thunderbird?
Flags: needinfo?(jp.willm)
Priority: P1 → --
Summary: Importing ~/.thunderbird fails → ~/.thunderbird profile directories copied to another PC do not work
Whiteboard: thunderbird restore backup failure → [closeme 2014-08-15]
(Reporter)

Comment 2

4 years ago
(In reply to Wayne Mery (:wsmwk) from comment #1)
> This worked in version 24?
> Do you get a crash reporter dialog when you attempt to start thunderbird?

No. Thunderbird starts, but I can not see the messages.
The different mail accounts are visible at the left side, but I can not open them

Thanks, jp in France
Flags: needinfo?(jp.willm)
(Reporter)

Comment 3

4 years ago
(In reply to Wayne Mery (:wsmwk) from comment #1)
> This worked in version 24?

Yes, I use successful this type of backup since years on different pc and os and thunderbird versions.

Comment 4

4 years ago
Is your mail data (the Local Directory path for each account) inside the .thunderbird folder?

Also, you CANNOT use the profile with an OLDER version of TB. Unless you know what changed between the versions and how the fix in the prefs.js file manually.
However, it should be possible to use a profile with a NEWER TB version. There is code to migrate profiles to newer versions, but there can't be the other way round.

See if bug 1043432 (the value of toolkit.telemetry.prompted pref) isn't your problem.
(Reporter)

Comment 5

4 years ago
(In reply to :aceman from comment #4)
> Is your mail data (the Local Directory path for each account) inside the
> .thunderbird folder?

Yes !


> 
> Also, you CANNOT use the profile with an OLDER version of TB. Unless you
> know what changed between the versions and how the fix in the prefs.js file
> manually.

Ok.


> However, it should be possible to use a profile with a NEWER TB version.
> There is code to migrate profiles to newer versions, but there can't be the
> other way round.

I can not use the profile folder on other PC, even with the same Thunderbird version n°31.

> 
> See if bug 1043432 (the value of toolkit.telemetry.prompted pref) isn't your
> problem.

My "toolkit.telemetry.prompted" line value is 2

It is probably not my problem...

Comment 6

4 years ago
Since you're on linux, did you check permissions were set properly for the copied files.
(Copying over the files should work.)
(Reporter)

Comment 7

4 years ago
(In reply to Magnus Melin from comment #6)
> Since you're on linux, did you check permissions were set properly for the
> copied files.

Yes, the permissions are correct : owner=user and 777


> (Copying over the files should work.)
I do it with rsync -r -n -t -v --progress --delete

Updated

4 years ago
Whiteboard: [closeme 2014-08-15]

Comment 8

2 years ago
jp, did you ever get this sorted out?
Flags: needinfo?(jp.willm)
Keywords: crash
Summary: ~/.thunderbird profile directories copied to another PC do not work → ~/.thunderbird profile directories copied to another PC with rsync, I can see accounts, but cannot see the messages
Whiteboard: [closeme 2016-08-01]

Comment 9

2 years ago
jp writes "No, alway the same problem :-/

I can create a new account with the same folders names and than copy/paste the different folders from the "Mail" directory."
Flags: needinfo?(jp.willm)

Updated

2 years ago
Whiteboard: [closeme 2016-08-01]

Comment 10

2 years ago
(In reply to jp willm from comment #0)
> Steps to reproduce:
> 
> backup of ~/.thunderbird and reuse this data on other PC's

From your description it is not clear at all what you're doing.
I'd suggest you post a question to the support forum for your issue.
https://support.mozilla.org/questions/new

Comment 11

a year ago
Is this still present in latest Thunderbird version?
Flags: needinfo?(jp.willm)
Whiteboard: [closeme 2017-05-15]
(Reporter)

Comment 12

a year ago
(In reply to Phoenix from comment #11)
> Is this still present in latest Thunderbird version?

Yes :-|

Meanwhile the PC has a fresh updated Xubuntu 16.4 with Thunderbird 45.8.0

But I still can not reuse my .thunderbird :-/


As always, I use grsync with this option rsync -r -t -v --progress --delete


What I get when I open TB is : http://www.cjoint.com/doc/17_04/GDyqnlH1QdR_tb-45.8.0.png

In the next days, I plan to install Manjaro 17.0.1 on this PC , then I will see if this problem remains...


Bonjour from France

jp willm
http://willms.pagesperso-orange.fr/
Flags: needinfo?(jp.willm)

Updated

a year ago
Whiteboard: [closeme 2017-05-15]
(Reporter)

Comment 13

a year ago
(In reply to jp willm from comment #12)

> In the next days, I plan to install Manjaro 17.0.1 on this PC , then I will
> see if this problem remains...

Now I use Manjaro Linux* 17.0.0 on all my PCs whith Thunderbird 52.0(64bit)

And nothing changes after syncing my .thunderbird folder from my desktop PC to my Labtop with grsync -r -t -v --progress --delete :-(

*
uname -a
Linux jp-manjaro 4.9.24-1-MANJARO #1 SMP PREEMPT Fri Apr 21 08:32:28 UTC 2017 x86_64 GNU/Linux


> jp willm
> http://willms.pagesperso-orange.fr/

Comment 14

a year ago
Is the path to the profile folder the same on all the machines where you copy the profile?
E.g. is your home/.thunderbird always at /home/jp/.thunderbird ? See in the prefs.js file inside the profile if there may be some full absolute paths stored in it. Also the file panacea.dat may store the full paths which may differ across your PCs. You may need to delete this file if the paths do not match.
(Reporter)

Comment 15

a year ago
(In reply to :aceman from comment #14)
> Is the path to the profile folder the same on all the machines where you
> copy the profile?
> E.g. is your home/.thunderbird always at /home/jp/.thunderbird ? See in the
> prefs.js file inside the profile if there may be some full absolute paths
> stored in it. Also the file panacea.dat may store the full paths which may
> differ across your PCs. You may need to delete this file if the paths do not
> match.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
(Reporter)

Updated

a year ago
Resolution: INVALID → WONTFIX
(Reporter)

Comment 16

a year ago
Bonjour,

> (In reply to :aceman from comment #14)
> > Is the path to the profile folder the same on all the machines where you
> > copy the profile?

This was the problem !

On the "master" PC :
[jp@jp-manjaro-open-rc ~]$ ls -al ~/.thunderbird
lrwxrwxrwx 1 jp jp 22 13 mai   16:44 /home/jp/.thunderbird -> /media/77/.thunderbird

On the "client" PC :
[jp@jp-manjaro ~]$ ls -al ~/.thunderbird
lrwxrwxrwx 1 jp jp 22 13 mai   16:54 /home/jp/.thunderbird -> /media/data/fixe/.thunderbird


> > E.g. is your home/.thunderbird always at /home/jp/.thunderbird ? See in the
> > prefs.js file inside the profile if there may be some full absolute paths
> > stored in it. Also the file panacea.dat may store the full paths which may
> > differ across your PCs. You may need to delete this file if the paths do not
> > match.

Yes in prefs.js, I have many lines like this :
user_pref("mail.server.server2.directory", "/media/77/.thunderbird/mna8c5lf.default/Mail/Local Folders");

Idem in the panacea.dat file.

Conclusion : thunderbird stores the real path and not the simlink path ~/.thunderbird
It's pity :-/

My workaround :

On the "client" PC, I changed the partition mount point "/media/data" to "/media/77" and store there .thunderbird and .mozilla folders.

And all works fine 8-)

Merci mille fois !
jp willm
Status: RESOLVED → VERIFIED

Comment 17

a year ago
(In reply to jp willm from comment #16)
> lrwxrwxrwx 1 jp jp 22 13 mai   16:54 /home/jp/.thunderbird ->
> /media/data/fixe/.thunderbird

> Yes in prefs.js, I have many lines like this :
> user_pref("mail.server.server2.directory",
> "/media/77/.thunderbird/mna8c5lf.default/Mail/Local Folders");
> 
> Idem in the panacea.dat file.
> 
> Conclusion : thunderbird stores the real path and not the simlink path
> ~/.thunderbird

Actually TB uses "mail.server.server2.directory-rel" preference if it exists. But if you use symlinks it is possible also these relative prefs got broken and stored as absolute paths.
We are trying to solve this in bug 760937. You may want to support us there ;)

Updated

a year ago
Depends on: 760937
(Reporter)

Comment 18

a year ago
Bonjour,

(In reply to :aceman from comment #17) 
> Actually TB uses "mail.server.server2.directory-rel" preference if it
> exists. But if you use symlinks it is possible also these relative prefs got
> broken and stored as absolute paths.

If I understand a little bit, the bug 760937 is a a thorny problem...


> We are trying to solve this in bug 760937.

Cool, I wish you reach the goal 8-)


> You may want to support us there
> ;)

Of course :-)

Merci encore !

jp willm
http://willms.pagesperso-orange.fr/
You need to log in before you can comment on or make changes to this bug.