belastingdienst.nl - javascript 1.2 error, page not displayed correctly

VERIFIED WORKSFORME

Status

Tech Evangelism Graveyard
Dutch
P3
normal
VERIFIED WORKSFORME
16 years ago
3 years ago

People

(Reporter: Rein Smedinga, Assigned: Tristan Nitot)

Tracking

Details

(Whiteboard: [PROPRIETARY-JS] [LAYER], URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

The above mentioned page is not displayed correctly.
The menu, that should appear at the right, with clickable
items is not displayed properly.

This might be an error in the javascript-engine. 
(Or is it that the developers of this page do not use 
standard javascript?)

Reproducible: Always, just visit the given url (and others in that domain)

Comment 1

16 years ago
Bad browser sniffing in http://www.belastingdienst.nl/2001/js/menu.js

Lots of code looks like this:

if (document.layers)
    // do stuff for netscape 4
else
    // do stuff for explorer with document.all

Document.layers and document.all are proprietary tags that mozilla doesn't support.

-> TE
Assignee: rogerl → nitot
Status: UNCONFIRMED → NEW
Component: Javascript Engine → Europe: West
Ever confirmed: true
OS: Windows 2000 → All
Product: Browser → Tech Evangelism
QA Contact: pschwartau → caillon
Hardware: PC → All
Whiteboard: [PROPRIETAEY-JS] [LAYER]
Version: other → unspecified

Updated

16 years ago
Whiteboard: [PROPRIETAEY-JS] [LAYER] → [PROPRIETARY-JS] [LAYER]
(Reporter)

Comment 2

16 years ago
But will it support these in the near future??

Comment 3

16 years ago
Mozilla will never support layers or document.all - they are non-standard and
just ugly hacks from the old browser war days.  The site needs to fix itself to
work with the W3C standard DOM.
Summary: javascript 1.2 error, page not displayed correctly → belastingdienst.nl - javascript 1.2 error, page not displayed correctly
(Reporter)

Comment 4

16 years ago
But layers and document.all and such was supported by Netscape 4.x
That means that Netscape 6.x will not be upwards compatible with NS4.x
(or was that not the intention in the first place)

Nevertheless, I agree to keep up the standards. 
Sorry for reporting this as a bug.

(Assignee)

Comment 5

16 years ago
Accepting bug. Confirming with build 2001111303.

setting P3.

contact info: redactie@belastingdienst.nl found on feedback page :
http://www.belastingdienst.nl/9229237/h/e-aanred.htm

Rein : don't be sorry to report this as a bug. This is indeed an evangelism bug.
I'll take care of it.
Status: NEW → ASSIGNED
Priority: -- → P3
(Reporter)

Comment 6

16 years ago
Thank you. 
So it is indeed a bug in Mozilla? Or is (also) a non-standard usage of javascript?

Comment 7

16 years ago
Rein, they are using bad javascript.  Bugs assigned to evangelism are where we
attempt to help the webmaster notice and fix the problem with their code.

Comment 8

16 years ago
*** Bug 119648 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
I tried to 'correct' their menu.js and some other javascript and css stuff in
their html pages. In about 30 minutes I got this working (locally) in Mozilla.
I'll send this code to them as a reference. It was in fact nothing more that
changing everything to getElementById() and some minor css changes.

Comment 10

16 years ago
Ronald : cool!  Can you also upload the attachment here for reference?  Thanks !
(Reporter)

Comment 11

16 years ago
Did the "belastingdienst" respond to this wonderful action?
Last week I checked, but the site was not changed and I had to use IE to
download some things.

Comment 12

16 years ago
Ronald: where dit you send it? I'd like to be able to complain somewhere...
(note to non-Dutch readers: the Belastingdienst is the Dutch tax office. Lots of
people are visiting this website to download the tax form software...)

Comment 13

16 years ago
I got an email from them: (in short: they don't care a thing) I will reply!

Geachte heer Bergsma,

In uw e-mailbericht geeft u aan, dat u problemen heeft met het bezoeken van
de internetpagina's van de Belastingdienst.

De Belastingdienst wil een zo groot mogelijk bereik krijgen voor zijn
informatievoorziening via het internet. Gelet op een beperkt beschikbaar
budget zullen vanuit effici├źntie echter keuzen gemaakt moeten worden voor de
ondersteuning van softwarecomponenten, waarmee het internet geraadpleegd
wordt. Immers, elk component heeft zijn eigen eigenaardigheden, die gevolgen
heeft voor de wijze waarop een internetpagina kan c.q. moet worden
geprogrammeerd. Deze keuzen worden gebaseerd op gebruikerscijfers alsmede de
gebruikersgegevens.

De Belastingdienst hanteert als richtliijn dat als een bepaalde component
voor ongeveer 5% wordt gebruikt dat de Belastingdienst aanleiding zal geven
de internetpagina's op die bepaalde component aan te passen.

Op dit moment houdt de Belastingdienst bij het bouwen van zijn
internetpagina's rekening met de volgende browsers:
- Internet Explorer 4.0 en hoger;
- Netscape 4.x.

Het gebruik van de overige browsers is op dit moment te klein (minder dan
0,5%) om ondersteund te worden.

Ik hoop u hiermee voldoende geïnformeerd te hebben.

Met vriendelijke groet,

R.N. Westmaas
Internetredactie Belastingdienst

(Reporter)

Comment 14

16 years ago
I've got the same reaction and replied to them that people have updated thier
code and made it working for Mozilla in about 30 minutes (as Ronald mentioned).

Ronald: did you ever got a reply from them after sending them the corrected code?

Comment 15

16 years ago
*** Bug 125247 has been marked as a duplicate of this bug. ***

Comment 16

16 years ago
Sorry for not responding...I've been on holiday

I to got the same response and no response on me sending them the code.... 

In short their site is a mess.... Why use a browsersniffer javascript library
when in many places it's not even used.... and separate 'tests' are done. There
is also many embeded javascript in pages that is common to all pages and should
be put in a separate js file. 

I hope they use more professional companies to develop software for their tax
systems....

Comment 17

16 years ago
Created attachment 69294 [details]
working example sent to the 'belastingdienst'

Created attachment with the example I made.... There are some minor issues but
the general idea works....

btw... It's strange that they say they do not support but look in the different

directories... 

Supprise........ there are 'nav6' css files....

Comment 18

16 years ago
<SPAM>
The example is a zip file...
</SPAM

Comment 19

16 years ago
For your information: I also sent those people of the "belastingdienst" an email
about their not working javascripts in Netscape 6.x and Mozilla. As expected, I
got the same answer as Mr. Bergsma got. They don't wake up over there.

Comment 20

16 years ago
The QA Contact for Europe: West has changed to
brantgurganus2001@cherokeescouting.org.  If there is a reason for you to stay as
the QA Contact, feel free to change back.
QA Contact: caillon → brantgurganus2001

Comment 21

15 years ago
The site has been redesigned, I believe most problems have been solved. Please
confirm and resolve accordingly.

Comment 22

15 years ago
confirmed, site working now
marking as wfm.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 24

15 years ago
v
Status: RESOLVED → VERIFIED
move...
Component: Europe: West → Dutch
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.